Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Try not to pollute the load path with duplicate entries

  • Loading branch information...
commit 68357887f4ed952acea30932920a39994ad55606 1 parent ad01f7d
@nicksieger authored
View
3  activerecord-jdbcderby-adapter/activerecord-jdbcderby-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbch2-adapter/activerecord-jdbch2-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbchsqldb-adapter/activerecord-jdbchsqldb-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbcmssql-adapter/activerecord-jdbcmssql-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbcmysql-adapter/activerecord-jdbcmysql-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbcpostgresql-adapter/activerecord-jdbcpostgresql-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
View
3  activerecord-jdbcsqlite3-adapter/activerecord-jdbcsqlite3-adapter.gemspec
@@ -1,5 +1,6 @@
# -*- encoding: utf-8 -*-
-$:.push File.expand_path("../../lib", __FILE__)
+arjdbc_lib = File.expand_path("../../lib", __FILE__)
+$:.push arjdbc_lib unless $:.include?(arjdbc_lib)
require 'arjdbc/version'
version = ArJdbc::Version::VERSION
Gem::Specification.new do |s|
Please sign in to comment.
Something went wrong with that request. Please try again.