This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

feat: add support for node 4

  • Loading branch information...
christophehurpeau committed Apr 1, 2017
1 parent aa0e8d4 commit 43eab81af4760b6f707a6bc1143b20cc27d4982b
Showing with 53 additions and 15 deletions.
  1. +1 −0 .pob.json
  2. +1 −0 .travis.yml
  3. +1 −1 index.js
  4. +21 −0 lib-older-node-dev/index.js
  5. +1 −0 lib-older-node-dev/index.js.map
  6. +21 −0 lib-older-node/index.js
  7. +1 −0 lib-older-node/index.js.map
  8. +1 −4 package.json
  9. +2 −7 test/.eslintrc.js
  10. +3 −3 yarn.lock
@@ -2,6 +2,7 @@
"envs": [
"node6",
"node7",
"older-node",
"module-modern-browsers",
"module",
"module-node7"
@@ -2,6 +2,7 @@ language: node_js
node_js:
- node
- "6"
- "4"

cache:
yarn: true
@@ -9,4 +9,4 @@ if (nodeVersionMajor > 7 || (nodeVersionMajor === 7 && nodeVersionMinor >= 6))
if (nodeVersionMajor > 6 || (nodeVersionMajor === 6 && nodeVersionMinor >= 5))
return module.exports = require('./lib-node6' + (production ? '' : '-dev') + '/index');
/* istanbul ignore next */
throw new Error('Node version not supported: ' + nodeVersion + ' (' + process.versions.node + ').');
return module.exports = require('./lib-older-node' + (production ? '' : '-dev') + '/index');

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
@@ -10,9 +10,6 @@
"license": "ISC",
"repository": "git@github.com:nightingalejs/nightingale-json-formatter.git",
"homepage": "https://github.com/nightingalejs/nightingale",
"engines": {
"node": ">=6.5.0"
},
"main": "./index.js",
"module": "./lib-module/index.js",
"module-dev": "./lib-module-dev/index.js",
@@ -43,7 +40,7 @@
"babel-preset-latest-node": "^0.2.2",
"babel-preset-modern-browsers": "^9.0.2",
"eslint": "^3.18.0",
"eslint-config-airbnb-base": "^11.1.1",
"eslint-config-airbnb-base": "^11.1.2",
"eslint-config-pob": "^11.1.0",
"eslint-plugin-babel": "^4.1.1",
"eslint-plugin-import": "^2.2.0",
@@ -2,11 +2,6 @@ exports.rules = {
"import/no-extraneous-dependencies": [2, {"devDependencies": true}]
};

exports.globals = {
suite: true,
test: true,
suiteSetup: true,
suiteTeardown: true,
setup: true,
teardown: true,
exports.env = {
mocha: true,
};

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

0 comments on commit 43eab81

Please sign in to comment.