Permalink
Switch branches/tags
Nothing to show
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
81 lines (51 sloc) 1.85 KB

Installation

Prerequisites

Before installing dryscrape, you need to install some software it depends on:

On Ubuntu you can do that with one command (the # indicates that you need root privileges for this):

# apt-get install qt5-default libqt5webkit5-dev build-essential \
                  python-lxml python-pip xvfb

Please note that Qt4 is also supported.

On Mac OS X, you can use Homebrew to install Qt and easy_install to install pip:

# brew install qt
# easy_install pip

On other operating systems, you can use pip to install lxml (though you might have to install libxml and the Python headers first).

Recommended: Installing dryscrape from PyPI

This is as simple as a quick

# pip install dryscrape

Note that dryscrape supports Python 2.7 and 3 as of version 1.0.

Installing dryscrape from Git

First, get a copy of dryscrape using Git:

$ git clone https://github.com/niklasb/dryscrape.git dryscrape
$ cd dryscrape

To install dryscrape, you first need to install webkit-server. You can use pip to do this for you (while still in the dryscrape directory).

# pip install -r requirements.txt

If you want, you can of course also install the dependencies manually.

Afterwards, you can use the setup.py script included to install dryscrape:

# python setup.py install