Browse files

[Locale] added more information to the README.md regarding the need t…

…o build the ICU data when the intl extension ICU data version mismatch the one shipped with Symfony
  • Loading branch information...
1 parent 3191c70 commit 33105e08d7f4995e107798431b9d5c075e2fcc0e @themightyi themightyi committed Aug 7, 2012
Showing with 5 additions and 1 deletion.
  1. +5 −1 src/Symfony/Component/Locale/README.md
View
6 src/Symfony/Component/Locale/README.md
@@ -23,10 +23,14 @@ You can run the unit tests with the following command:
If your PHP have the ``intl`` extension enabled but the intl extension ICU data
version mismatch the one shipped with the component, you can build the data for
-it and use the ``USE_INTL_ICU_DATA_VERSION`` environment variable:
+it and use the ``USE_INTL_ICU_DATA_VERSION`` environment variable.
+ php Resources/data/build-data.php
export USE_INTL_ICU_DATA_VERSION=true
phpunit
+This way the tests will use the ICU data files with the same version of your
+``intl`` extension.
+
Read the file ``Resources/data/UPDATE.txt`` for more info about building or
updating the ICU data files.

0 comments on commit 33105e0

Please sign in to comment.