Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

execShellCmd returns 0 instead of nonzero when child process exits with signal (eg SIGSEGV) #10273

Closed
timotheecour opened this issue Jan 11, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@timotheecour
Copy link
Contributor

commented Jan 11, 2019

execShellCmd returns 0 instead of nonzero when child process exits with signal (eg SIGSEGV)

EDIT:
for test case: see tests/stdlib/tosproc.nim in PR #10274 ; it fails before that PR and succeeds after PR

@timotheecour timotheecour added the osproc label Jan 11, 2019

@timotheecour timotheecour self-assigned this Jan 11, 2019

timotheecour added a commit to timotheecour/Nim that referenced this issue Jan 11, 2019

timotheecour added a commit to timotheecour/Nim that referenced this issue Jan 11, 2019

timotheecour added a commit to timotheecour/Nim that referenced this issue Jan 12, 2019

@Araq Araq closed this in #10274 Jan 13, 2019

Araq added a commit that referenced this issue Jan 13, 2019

fixes #10273 execShellCmd now returns nonzero when child killed with …
…signal + other fixes (#10274)

* s/exitStatus(...)/exitStatusLikeShell(...)/
* fix #10273 execShellCmd now returns nonzero when child exits with signal
* test case for #10249 and explanation for the bug
* fix test failure
* add tests/nim.cfg
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.