Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

devel docs in nim-lang.github.io Source links point to master instead of devel #9295

Closed
timotheecour opened this issue Oct 10, 2018 · 3 comments · Fixed by #9299
Closed

devel docs in nim-lang.github.io Source links point to master instead of devel #9295

timotheecour opened this issue Oct 10, 2018 · 3 comments · Fixed by #9299

Comments

@timotheecour
Copy link
Member

@timotheecour timotheecour commented Oct 10, 2018

reproducible example:

in https://nim-lang.github.io/Nim/ospaths.html#lastPathPart%2Cstring click on "source", it points to https://github.com/nim-lang/Nim/blob/master/lib/pure/ospaths.nim#L409 (which points to something random, unrelated to lastPathPart) instead of the correct https://github.com/nim-lang/Nim/blob/devel/lib/pure/ospaths.nim#L409 from devel.

hints for a fix

see my PR #8423 where I had fixed the exact same problem for locally built docs: #8420 (locally built docs point to wrong branch in Source link (Edit one is ok though))
probably just a matter of introducing --git.commit:devel in the command where devel docs are built to nim-lang.github.io

@kaushalmodi
Copy link
Contributor

@kaushalmodi kaushalmodi commented Oct 10, 2018

in the command where devel docs are built to nim-lang.github.io

That would be here:

- ./koch docs

As you found the issue and solution, feel free it test it out and PR it :)

Thanks.

timotheecour added a commit to timotheecour/Nim that referenced this issue Oct 10, 2018
@Araq Araq closed this in #9299 Oct 11, 2018
Araq added a commit that referenced this issue Oct 11, 2018
krux02 added a commit to krux02/Nim that referenced this issue Oct 15, 2018
@timotheecour
Copy link
Member Author

@timotheecour timotheecour commented Oct 29, 2018

/cc @kaushalmodi
re-opening, problem still there; this is odd, because IIRC, when I ran ./koch docs --git.commit:devel locally (as I did in #9299) it fixed this issue for me (maybe a regression since then, or maybe the proper place to add --git.commit:devel is not in .travis.yml

@timotheecour
Copy link
Member Author

@timotheecour timotheecour commented Feb 3, 2019

fixed by #10529 ; thanks @narimiran !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

2 participants