Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 43 lines (38 sloc) 1.652 kb
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
1 #!/usr/bin/env pythonv
2
399d33b3 » buzztroll
2012-05-18 picking up the package data
3 from setuptools import setup, find_packages
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
4
5 import sys
399d33b3 » buzztroll
2012-05-18 picking up the package data
6 Version = "0.2.1"
7 Name = "phantomweb"
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
8
9 if float("%d.%d" % sys.version_info[:2]) < 2.6:
10 sys.stderr.write("Your Python version %d.%d.%d is not supported.\n" % sys.version_info[:3])
399d33b3 » buzztroll
2012-05-18 picking up the package data
11 sys.stderr.write("%s requires Python 2.6 or newer.\n" % (Name))
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
12 sys.exit(1)
13
399d33b3 » buzztroll
2012-05-18 picking up the package data
14 setup(name=Name,
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
15 version=Version,
16 description='A Django app for Nimbus Autoscale',
17 author='Nimbus Development Team',
18 author_email='workspace-user@globus.org',
19 url='http://www.nimbusproject.org/',
20 keywords = "Nimbus auto scale",
21 long_description="""Some other time""",
22 license="Apache2",
399d33b3 » buzztroll
2012-05-18 picking up the package data
23 packages=['phantomweb'],
24 include_package_data=True,
25 package_data={ 'phantomweb': ['templates/registration/*.html', 'templates/*.html', 'static/css/*', 'static/js/*', 'static/images/*'] },
56268df2 » buzztroll
2012-10-11 upping the boto version
26 install_requires = ["django == 1.4", "boto == 2.6", "phantomsql", "ceiclient"],
428a8446 » buzztroll
2012-05-18 adding a setup file to get deps
27
28 classifiers=[
29 'Development Status :: 4 - Beta',
30 'Environment :: Console',
31 'Intended Audience :: End Users/Desktop',
32 'Intended Audience :: Developers',
33 'Intended Audience :: System Administrators',
34 'License :: OSI Approved :: Apache Software License',
35 'Operating System :: MacOS :: MacOS X',
36 'Operating System :: Microsoft :: Windows',
37 'Operating System :: POSIX',
38 'Operating System :: POSIX :: Linux',
39 'Programming Language :: Python',
40 'Topic :: System :: Clustering',
41 'Topic :: System :: Distributed Computing',
42 ],
43 )
Something went wrong with that request. Please try again.