Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 46 lines (41 sloc) 1.879 kb
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
1 #!/usr/bin/env pythonv
2
942b378 Pierre Riteau Update Django to the latest 1.4.x release
priteau authored
3 from setuptools import setup
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
4
5 import sys
399d33b John Bresnahan picking up the package data
buzztroll authored
6 Version = "0.2.1"
7 Name = "phantomweb"
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
8
9 if float("%d.%d" % sys.version_info[:2]) < 2.6:
10 sys.stderr.write("Your Python version %d.%d.%d is not supported.\n" % sys.version_info[:3])
399d33b John Bresnahan picking up the package data
buzztroll authored
11 sys.stderr.write("%s requires Python 2.6 or newer.\n" % (Name))
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
12 sys.exit(1)
13
399d33b John Bresnahan picking up the package data
buzztroll authored
14 setup(name=Name,
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
15 version=Version,
16 description='A Django app for Nimbus Autoscale',
17 author='Nimbus Development Team',
18 author_email='workspace-user@globus.org',
19 url='http://www.nimbusproject.org/',
20 keywords = "Nimbus auto scale",
21 long_description="""Some other time""",
22 license="Apache2",
bd6cd8b Patrick Armstrong Add templatetags to included packages
oldpatricka authored
23 packages=['phantomweb', 'phantomweb.templatetags'],
399d33b John Bresnahan picking up the package data
buzztroll authored
24 include_package_data=True,
25 package_data={ 'phantomweb': ['templates/registration/*.html', 'templates/*.html', 'static/css/*', 'static/js/*', 'static/images/*'] },
942b378 Pierre Riteau Update Django to the latest 1.4.x release
priteau authored
26 install_requires = ["django >= 1.4, < 1.5", "boto == 2.6", "phantomsql == 0.2.1", "ceiclient"],
c0e0579 Pierre Riteau Add dependency_links for pip2pi
priteau authored
27 dependency_links=[
28 "http://github.com/nimbusproject/PhantomSQL/tarball/master#egg=phantomsql-0.2.1",
29 "http://github.com/nimbusproject/ceiclient/tarball/master#egg=ceiclient-0.1"],
428a844 John Bresnahan adding a setup file to get deps
buzztroll authored
30 classifiers=[
31 'Development Status :: 4 - Beta',
32 'Environment :: Console',
33 'Intended Audience :: End Users/Desktop',
34 'Intended Audience :: Developers',
35 'Intended Audience :: System Administrators',
36 'License :: OSI Approved :: Apache Software License',
37 'Operating System :: MacOS :: MacOS X',
38 'Operating System :: Microsoft :: Windows',
39 'Operating System :: POSIX',
40 'Operating System :: POSIX :: Linux',
41 'Programming Language :: Python',
42 'Topic :: System :: Clustering',
43 'Topic :: System :: Distributed Computing',
44 ],
45 )
Something went wrong with that request. Please try again.