Permalink
Browse files

adding the setup install program

  • Loading branch information...
1 parent 2741779 commit 159996200536215ba3f98ee0da862c09cb47b20e BuzzTroll committed Oct 6, 2010
Showing with 29 additions and 0 deletions.
  1. +29 −0 setup.py
View
29 setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+import sys
+
+py_version = 2.5
+Version=0.1
+
+if float("%d.%d" % sys.version_info[:2]) < py_version:
+ sys.stderr.write("Your Python version %d.%d.%d is not supported.\n" % sys.version_info[:3])
+ sys.stderr.write("cloudminer requires Python %f or newer.\n" % (py_version))
+ sys.exit(1)
+
+setup(name='cloudminer',
+ version=Version,
+ description='An persistnace API for the cloudyvents API.',
+ author='Nimbus Team',
+ author_email='nimbusteam@mcs.anl.gov',
+ url='http://www.nimbusproject.org/',
+ packages=[ 'cloudminer', 'cloudminer.tests' ],
+ long_description="""
+""",
+ license="Apache2",
+ install_requires = ["nose", "cloudyvents"],
+ )

0 comments on commit 1599962

Please sign in to comment.