Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Fetching contributors…

Cannot retrieve contributors at this time

52 lines (46 sloc) 1.811 kB
#!/usr/bin/env pythonv
# Copyright 2013 University of Chicago
try:
from setuptools import setup, find_packages
except ImportError:
from distutils.core import setup
import sys
version = '2.1.1'
if float("%d.%d" % sys.version_info[:2]) < 2.5:
sys.stderr.write("Your Python version %d.%d.%d is not supported.\n" % sys.version_info[:3])
sys.stderr.write("eeagent requires Python 2.5 or newer.\n")
sys.exit(1)
setup(name='eeagent',
version=version,
description='Execution Engine Agent',
author='Nimbus Development Team',
author_email='workspace-user@globus.org',
url='http://www.nimbusproject.org/',
packages=find_packages(),
package_data={'eeagent': ['config/*.yml']},
dependency_links=['http://sddevrepo.oceanobservatories.org/releases'],
keywords = "OOI Execution Agent",
long_description="""Some other time""",
license="Apache2",
install_requires = ["dashi", "pidantic", "simplejson"],
entry_points = {
'console_scripts': [
'eeagent = eeagent.agent:main',
'eeagentclient = eeagent.client:main',
],},
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: Developers',
'Intended Audience :: System Administrators',
'License :: OSI Approved :: Apache Software License',
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX',
'Operating System :: POSIX :: Linux',
'Programming Language :: Python',
'Topic :: System :: Clustering',
'Topic :: System :: Distributed Computing',
],
)
Jump to Line
Something went wrong with that request. Please try again.