Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Add requirements.txt for less error prone deployment

  • Loading branch information...
commit 2ba3520d9d00ea58794f311ae3b89daa4a70f944 1 parent ba945c4
@oldpatricka oldpatricka authored
Showing with 31 additions and 1 deletion.
  1. +7 −1 README.md
  2. +24 −0 requirements.txt
View
8 README.md
@@ -66,4 +66,10 @@ When you're ready to stop the service, you can do so like so:
Installation
------------
- python setup.py install
+For deployment:
+
+ pip install -r requirements.txt
+
+For development of epu-harness itself:
+
+ python setup.py develop
View
24 requirements.txt
@@ -0,0 +1,24 @@
+Fabric==1.3.0
+Jinja2==2.6
+PyYAML==3.10
+SQLAlchemy==0.7.6
+apache-libcloud==0.8.0
+-e git+git://github.com/nimbusproject/ceiclient.git#egg=ceiclient
+-e git+git://github.com/nimbusproject/cloudinit.d.git#egg=cloudinitd
+dashi==0.1.0
+-e git+git://github.com/nimbusproject/eeagent.git#egg=eeagent
+-e git+git://github.com/ooici/epu.git#egg=epu
+-e git+git://github.com/nimbusproject/epuharness.git#egg=epuharness
+gevent==0.13.6
+greenlet==0.3.4
+httplib2==0.7.1
+kombu==2.1.8
+mock==0.8.0
+nimboss==0.4.6
+nose==1.1.2
+-e git+git://github.com/nimbusproject/pidantic.git#egg=pidantic
+pycrypto==2.3
+simplejson==2.5.0
+supervisor==3.0a12
+uuid==1.30
+wsgiref==0.1.2
Please sign in to comment.
Something went wrong with that request. Please try again.