Extends puppet-lint to ensure that your manifests have no global resources.
Switch branches/tags
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lib/puppet-lint/plugins
spec
.gitignore
.rubocop.yml
.travis.yml
Gemfile
README.md
Rakefile
puppet-lint-global_resource-check.gemspec

README.md

puppet-lint global resource check

Build Status Gem Version

Installation

To use this plugin, add the following like to the Gemfile in your Puppet code base and run bundle install.

gem 'puppet-lint-global_resource-check', '~> 0.3.0'

For puppet-lint version 1.1

gem 'puppet-lint-global_resource-check', '~> 0.2.0'

Usage

This plugin provides a new check to puppet-lint.

global_resource

--fix support: No

This check will raise a error for any global defines resource.

ERROR: Resource file in global space on line 19