Cowboy don't work when i try to run the bigwig #293

Colinhuu opened this Issue Oct 19, 2012 · 4 comments


None yet

3 participants


I always got the init terminating in do_boot () error when try to run the bigwig.

such as follows

ERLANG:/usr/local/erlang/bigwig # ./
==> cowboy (compile)
==> jsx (compile)
==> bigwig (compile)
Erlang R13B04 (erts-5.7.5) [source] [smp:4:4] [rq:4] [async-threads:0] [hipe] [kernel-poll:false]

Eshell V5.7.5 (abort with ^G)
(bigwig@> {"init terminating in do_boot",{{case_clause,{error,{bad_return,{{cowboy_app,start,[normal,[]]},{'EXIT',{undef,[{cowboy_app,start,[normal,[]]},{application_master,start_it_old,4}]}}}}}},[{bigwig,ensure_started,1},{bigwig,start,0},{init,start_it,1},{init,start_em,1}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()

i am running SUSE 10 and the erlang version is R13B04 , and the cowboy version is 0.6.0

somebody help me

Nine Nines member

Hey, are you sure Cowboy compiled correctly? It's not supposed to work with R13B04.


==> cowboy (get-deps)
Pulling ranch from {git,"git://",
Cloning into 'ranch'...
error: pathspec 'origin/cd099983b1b807b87fa050d1e4ff0a13aba25b49' did not match any file(s) known to git.
ERROR: git checkout -q origin/cd099983b1b807b87fa050d1e4ff0a13aba25b49 failed with error: 1

Nine Nines member

Your rebar (or the one in bigwig?) is outdated. Update it and it'll pull Ranch correctly.

Nine Nines member

Closing this, hope you guys are good with it.

@essen essen closed this Nov 27, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment