New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Documentation does not mention Scipy as a dependency for VTK widgets. #1020

Closed
theaverageguy opened this Issue Mar 25, 2016 · 6 comments

Comments

Projects
None yet
4 participants
@theaverageguy
Contributor

theaverageguy commented Mar 25, 2016

While working with VTK widgets I came across the error:
no module named scipy.interpolate.

Obviously scipy needs to be installed but the documentation does not warn us about this.
Will take this up.

@sahmed95

This comment has been minimized.

Contributor

sahmed95 commented Mar 25, 2016

Can you please give a link to the file from where you get the error. Or post a code snippet how you got it? You can use http://paste.ubuntu.com/. Even I want to understand how to deal with VTK.

@arokem

This comment has been minimized.

Member

arokem commented Mar 25, 2016

Dependencies are described here:
http://nipy.org/dipy/dependencies.html#dependencies

On Fri, Mar 25, 2016 at 7:51 AM, Shahnawaz Ahmed notifications@github.com
wrote:

Can you please give a link to the file from where you get the error. Or
post a code snippet how you got it? You can use http://paste.ubuntu.com/.
Even I want to understand how to deal with VTK.


You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub
#1020 (comment)

@arokem

This comment has been minimized.

Member

arokem commented Mar 25, 2016

And that's linked from here: http://nipy.org/dipy/installation.html

But happy to add it in other places, if it makes it easier.

On Fri, Mar 25, 2016 at 7:53 AM, Ariel Rokem arokem@gmail.com wrote:

Dependencies are described here:
http://nipy.org/dipy/dependencies.html#dependencies

On Fri, Mar 25, 2016 at 7:51 AM, Shahnawaz Ahmed <notifications@github.com

wrote:

Can you please give a link to the file from where you get the error. Or
post a code snippet how you got it? You can use http://paste.ubuntu.com/.
Even I want to understand how to deal with VTK.


You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub
#1020 (comment)

@matthew-brett

This comment has been minimized.

Member

matthew-brett commented Mar 25, 2016

When #1019 is merged, dipy should install scipy automatically.

@theaverageguy

This comment has been minimized.

Contributor

theaverageguy commented Mar 27, 2016

I am working on VTK Widgets from now on for my application in GSoC. I would like to contribute with about 2-3 widgets this week.
Thanks. :)

@arokem

This comment has been minimized.

Member

arokem commented Apr 13, 2016

I think we can close this one (feel free to reopen if I've missed something)

@arokem arokem closed this Apr 13, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment