New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug] connectivity matrix image in streamline_tools example #1154

Closed
mdesco opened this Issue Nov 25, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@mdesco
Contributor

mdesco commented Nov 25, 2016

The connectivity.png figure in the example shows three subfigures (2 rtop figures from EAP estimation and the connectivity matrix with "msd" over it). See here.

I don't know where this comes from but is wrong. Only the connectivity matrix should be displayed. I have looked at the code and it seems right...

screenshot 2016-11-25 13 42 54

@arokem

This comment has been minimized.

Member

arokem commented Nov 25, 2016

Thanks for reporting! Looks like we have an issue with cleaning up figures between examples. My theory is that this was introduced in this commit: 55166f7. I think that plt.close('all') might have been there to do the cleanup after each example (and was removed in that commit). @Garyfallidis : WDYT?

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 28, 2016

I can replicate the issue. Let me try it and will get back to you.

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 30, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment