New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Should we retire our Python 3.5 travis builds? #1562

Closed
arokem opened this Issue Jun 11, 2018 · 4 comments

Comments

Projects
None yet
3 participants
@arokem
Copy link
Member

arokem commented Jun 11, 2018

Any reason to keep these around?

@matthew-brett

This comment has been minimized.

Copy link
Member

matthew-brett commented Jun 11, 2018

Are you planning to drop support for Python 3.5?

@skoudoro

This comment has been minimized.

Copy link
Member

skoudoro commented Jun 11, 2018

Any reason to keep these around?

  • By default, Conda-Smithy generates packages for Python 2.7, 3.5 and 3.6.
  • It seems we still have some download from python3.5 on all platforms.

Otherwise, I do not see other reason...

@matthew-brett

This comment has been minimized.

Copy link
Member

matthew-brett commented Jun 11, 2018

I would have thought Python 2.7, 3.5 and 3.6 was a reasonable list. Dropping 3.5 seems a bit premature, even when 3.7 comes out. Don't all your dependencies still support 3.5?

@arokem

This comment has been minimized.

Copy link
Member

arokem commented Jun 12, 2018

OK - I guess that's a "no"! Thanks.

@arokem arokem closed this Jun 12, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment