Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add python_requires=">=3.5" #1906

Closed
effigies opened this issue Jul 17, 2019 · 2 comments

Comments

@effigies
Copy link
Member

commented Jul 17, 2019

Description

I noticed that you've dropped tests, and presumably support, for Python 2.7 and 3.4. If you add the python_requires=">= 3.5" option to your setuptools.setup() call, then Python versions lower than 3.5 will not attempt to install versions built with that option.

It looks like the main effect in version 0.16.0 is that 2.7 and 3.4 manylinux wheels aren't getting built, so it just takes longer to install, but future versions will eventually break, so avoiding the installation would be nice.

@skoudoro

This comment has been minimized.

Copy link
Member

commented Jul 17, 2019

If you add the python_requires=">= 3.5" ....

Thank you @effigies, that's a good idea, will do!

@skoudoro

This comment has been minimized.

Copy link
Member

commented Jul 21, 2019

fixed by #1911, closing

@skoudoro skoudoro closed this Jul 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.