New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MRG: bumpy numpy requirement to 1.5 / compat fixes #374

Merged
merged 4 commits into from Jun 20, 2014

Conversation

Projects
None yet
3 participants
@matthew-brett
Member

matthew-brett commented Jun 3, 2014

Increase numpy version requirement to 1.5 as fix for error missing
'np.percentile' on buildbots.

Refactor calls to ones_like, zeros_like for compatibility with older numpy.

matthew-brett added some commits Jun 3, 2014

BF: don't use dtype with ones/zeros_like
Use ones/zeros(arr.shape, dtype) instead - for compatibility with older
numpy - at least numpy 1.5.0 does not have this.
@@ -74,7 +74,7 @@
"""
# versions for dependencies
NUMPY_MIN_VERSION='1.3'
NUMPY_MIN_VERSION='1.5'
SCIPY_MIN_VERSION='0.7.2'

This comment has been minimized.

@MrBago

MrBago Jun 4, 2014

Contributor

I believe we discussed on the mail list bumping the scipy version to 0.10.1 if we do that, we can also safely bump numpy to 1.6 because I think it came out before scipy .10.1.

This comment has been minimized.

@arokem

arokem Jun 4, 2014

Member

Yes - let's do that here as well. I think that we reached consensus on
that, and got Yarik's approval for that move.

On Wed, Jun 4, 2014 at 12:23 PM, MrBago notifications@github.com wrote:

In dipy/info.py:

@@ -74,7 +74,7 @@
"""

versions for dependencies

-NUMPY_MIN_VERSION='1.3'
+NUMPY_MIN_VERSION='1.5'
SCIPY_MIN_VERSION='0.7.2'

I believe we discussed on the mail list bumping the scipy version to
0.10.1 if we do that, we can also safely bump numpy to 1.6 because I think
it came out before scipy .10.1.


Reply to this email directly or view it on GitHub
https://github.com/nipy/dipy/pull/374/files#r13405182.

@arokem

This comment has been minimized.

Member

arokem commented Jun 18, 2014

Hey @matthew-brett - just reminding you about this one. Could you make those changes, and we'll merge this? Thanks!

@matthew-brett

This comment has been minimized.

Member

matthew-brett commented Jun 19, 2014

Causing build error on travis due to scipy 0.9.0 - OK to drop requirement to that until travis upgrades? It's not a very old ubuntu.

@arokem

This comment has been minimized.

Member

arokem commented Jun 19, 2014

Seems fine to me.

On Thu, Jun 19, 2014 at 5:44 AM, Matthew Brett notifications@github.com
wrote:

Causing build error on travis due to scipy 0.9.0 - OK to drop requirement
to that until travis upgrades? It's not a very old ubuntu.


Reply to this email directly or view it on GitHub
#374 (comment).

@matthew-brett

This comment has been minimized.

Member

matthew-brett commented Jun 19, 2014

Unrelated memory allocation failure. I think this one's OK to merge if y'all agree on scipy 0.9.0 for now.

arokem added a commit that referenced this pull request Jun 20, 2014

Merge pull request #374 from matthew-brett/numpy-compat-fixes
MRG: bumpy numpy requirement to 1.5 / compat fixes

@arokem arokem merged commit db6392f into nipy:master Jun 20, 2014

1 check failed

continuous-integration/travis-ci The Travis CI build failed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment