New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Report on coverage for old scipy. #479

Merged
merged 1 commit into from Nov 25, 2014

Conversation

Projects
None yet
3 participants
@arokem
Member

arokem commented Nov 23, 2014

This might be the thing. That machine tests for the minimal versions of our dependency - meaning scipy==0.9. If we have a coverage report here as well, we can check for both minimal dependencies and typical dependencies. Together - these should give full coverage on dipy.core.optimize

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 24, 2014

Okay if you see now coverage for optimize is much higher 77% for old scipy versions.

@arokem

This comment has been minimized.

Member

arokem commented Nov 24, 2014

Yes. But we have to go back and forth between these two machines to assess
coverage. I don't really see any way around this, though.

On Sun, Nov 23, 2014 at 4:12 PM, Eleftherios Garyfallidis <
notifications@github.com> wrote:

Okay if you see now coverage for optimize is much higher 77% for old scipy
versions.


Reply to this email directly or view it on GitHub
#479 (comment).

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 24, 2014

Neither I. @matthew-brett do you have any suggestions?

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 24, 2014

Of course we can change our minimum version to Scipy 0.11 or 0.12. And then we will have no problem with coverage. I have to say that the amount of time that I spent to make things work across older scipy versions is overwhelming. Maybe we are overkilling ourselves. Anyway @matthew-brett and @arokem let me know what you think.

@Garyfallidis

This comment has been minimized.

Member

Garyfallidis commented Nov 24, 2014

Another alternative is that I raise an Error when people use streamline-based linear registration (SLR) with old Scipy versions saying that "This algorithm is only available with Scipy >= 0.12". Any other suggestions?

@samuelstjean

This comment has been minimized.

Contributor

samuelstjean commented Nov 24, 2014

Not supporting an old version seems easier, it's probably only gonna raise further issues down the road. Ubuntu 14.04 and the next debian are using scipy > 0.12, but the old ones are at 0.9 and 0.10 respectively.

Garyfallidis added a commit that referenced this pull request Nov 25, 2014

Merge pull request #479 from arokem/travis-old-scipy
Report on coverage for old scipy.

@Garyfallidis Garyfallidis merged commit 6239c10 into nipy:master Nov 25, 2014

1 check passed

continuous-integration/travis-ci The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment