Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP


update dependency for most recent pry release #13

merged 1 commit into from

6 participants

John Mair Jimmy Cuadra dsisnero Conrad Irwin Billingsly Wetherfordshire Gopal Patel
John Mair

pry 0.9.9 has been released, time to update dependency ;)

Jimmy Cuadra

Wouldn't it be better to use >= instead of ~> so there doesn't need to be a new version of pry-nav every time a new pry is released that increases the penultimate version number? As it stands, I'm now waiting on a release of this gem to update Pry in my app.

John Mair

@jimmycuadra The next version we expect to be 1.0 and i can't guarantee backwards compat from 1.0 to 0.9.9


Can we get this applied and have a new version put out?

Conrad Irwin

I'd vote for just changing it to >=, it seems unlikely that too much would break; and having to update the version number of a dependency every time gets pretty old.

(but whatever, we should do it ASAP, not having pry-nav is like not having a thumb on your right hand).

John Mair

@nixme, As i stated in the email i sent today, im happy to take over the mundane process of releasing future pry-nav gems; feel free to add me as a gem owner/repository collaborator :)

Gopal Patel

@banister. Added you as a collaborator. I'll do a release right now.

Gopal Patel nixme merged commit 9343db4 into from
Gopal Patel

Released 0.2.1.

I'd rather stay away from using >= especially with the level of money-patching going on in pry-nav. I did make a mistake with the last release tying the approx operator to the patch level instead of one up. If we stick to three digits then minor releases of pry should match up fine. Or perhaps pry can adopt strict semver past 1.0? What do you think?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 18, 2012
  1. John Mair
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  pry-nav.gemspec
2  pry-nav.gemspec
@@ -19,6 +19,6 @@ do |gem|
# Dependencies
gem.required_ruby_version = '>= 1.8.7'
- gem.add_runtime_dependency 'pry', '~>'
+ gem.add_runtime_dependency 'pry', '~> 0.9.9'
gem.add_development_dependency 'pry-remote', '~> 0.1.1'
Something went wrong with that request. Please try again.