Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

update dependency for most recent pry release #13

Merged
merged 1 commit into from

6 participants

@banister
Collaborator

pry 0.9.9 has been released, time to update dependency ;)

@jimmycuadra

Wouldn't it be better to use >= instead of ~> so there doesn't need to be a new version of pry-nav every time a new pry is released that increases the penultimate version number? As it stands, I'm now waiting on a release of this gem to update Pry in my app.

@banister
Collaborator

@jimmycuadra The next version we expect to be 1.0 and i can't guarantee backwards compat from 1.0 to 0.9.9

@dsisnero

Can we get this applied and have a new version put out?

@ConradIrwin

I'd vote for just changing it to >=, it seems unlikely that too much would break; and having to update the version number of a dependency every time gets pretty old.

(but whatever, we should do it ASAP, not having pry-nav is like not having a thumb on your right hand).

@banister
Collaborator

@nixme, As i stated in the email i sent today, im happy to take over the mundane process of releasing future pry-nav gems; feel free to add me as a gem owner/repository collaborator :)

@nixme
Owner

@banister. Added you as a collaborator. I'll do a release right now.

@nixme nixme merged commit 9343db4 into nixme:master
@nixme
Owner

Released 0.2.1.

I'd rather stay away from using >= especially with the level of money-patching going on in pry-nav. I did make a mistake with the last release tying the approx operator to the patch level instead of one up. If we stick to three digits then minor releases of pry should match up fine. Or perhaps pry can adopt strict semver past 1.0? What do you think?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 18, 2012
  1. @banister
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  pry-nav.gemspec
View
2  pry-nav.gemspec
@@ -19,6 +19,6 @@ Gem::Specification.new do |gem|
# Dependencies
gem.required_ruby_version = '>= 1.8.7'
- gem.add_runtime_dependency 'pry', '~> 0.9.8.1'
+ gem.add_runtime_dependency 'pry', '~> 0.9.9'
gem.add_development_dependency 'pry-remote', '~> 0.1.1'
end
Something went wrong with that request. Please try again.