New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Stopped working in Firefox Nightly (10/10/2015). #21

Closed
joder666 opened this Issue Oct 10, 2015 · 35 comments

Comments

Projects
None yet
@joder666

Today i noticed that went i try "about:addons-memory" on a new tab i get:

The address isn't valid
The URL is not valid and cannot be loaded.

Web addresses are usually written like http://www.example.com/
Make sure that you're using forward slashes (i.e. /).

I install the addon in a clean profile, and tried "e10" on and off, it did not worked.
Also i turned to false "xpinstall.signatures.required", no go.

It works ok on Firefox 41.01.

@Bugsbane

This comment has been minimized.

Show comment
Hide comment
@Bugsbane

Bugsbane Dec 17, 2015

Getting this error on Firefox 43 on Ubuntu 15.10.

Getting this error on Firefox 43 on Ubuntu 15.10.

@jeffgrammer

This comment has been minimized.

Show comment
Hide comment
@jeffgrammer

jeffgrammer Dec 29, 2015

Getting this same error on FF 45.0a2 using Windows 10

Getting this same error on FF 45.0a2 using Windows 10

@Smile4ever

This comment has been minimized.

Show comment
Hide comment
@Smile4ever

Smile4ever Dec 29, 2015

@Bugsbane
@reconrey
Make sure the about:config entry xpinstall.signatures.required is set to false or manually remove the addon and reinstall from here: https://addons.mozilla.org/firefox/addon/about-addons-memory/

@Bugsbane
@reconrey
Make sure the about:config entry xpinstall.signatures.required is set to false or manually remove the addon and reinstall from here: https://addons.mozilla.org/firefox/addon/about-addons-memory/

@Smile4ever

This comment has been minimized.

Show comment
Hide comment
@Smile4ever

Smile4ever Dec 29, 2015

I confirm about:addons-memory is no longer working in Firefox 46 (signed version used, no e10s).

I confirm about:addons-memory is no longer working in Firefox 46 (signed version used, no e10s).

@jeffgrammer

This comment has been minimized.

Show comment
Hide comment
@jeffgrammer

jeffgrammer Dec 29, 2015

@Smile4ever
Setting xpinstall.signatures.required to false and removing/reinstalling the extension did not work

@Smile4ever
Setting xpinstall.signatures.required to false and removing/reinstalling the extension did not work

@Smile4ever

This comment has been minimized.

Show comment
Hide comment
@Smile4ever

Smile4ever Dec 29, 2015

Okay then you are facing the same issue because your Firefox version >=45. We need the developer to look at this.

Okay then you are facing the same issue because your Firefox version >=45. We need the developer to look at this.

@jeffgrammer

This comment has been minimized.

Show comment
Hide comment
@jeffgrammer

jeffgrammer Dec 29, 2015

Intresting. I did a bit more testing on this using an Ubuntu 15.10 VM and I was able to get it to work on the 43.0 release channel, but once I updated to the beta channel, 44.0b4, it stopped working. So, perhaps this issue is related to it not being supported on non-release channels? It does seem odd that @Bugsbane was getting this issue with Firefox 43 using Ubuntu 15.10 and I am not however. Not sure if this project will get revived, but it has not been updated for over a year, so I'm not sure if we will get an official fix for this.

Intresting. I did a bit more testing on this using an Ubuntu 15.10 VM and I was able to get it to work on the 43.0 release channel, but once I updated to the beta channel, 44.0b4, it stopped working. So, perhaps this issue is related to it not being supported on non-release channels? It does seem odd that @Bugsbane was getting this issue with Firefox 43 using Ubuntu 15.10 and I am not however. Not sure if this project will get revived, but it has not been updated for over a year, so I'm not sure if we will get an official fix for this.

@Smile4ever

This comment has been minimized.

Show comment
Hide comment
@Smile4ever

Smile4ever Dec 29, 2015

@Bugsbane is not facing this issue but rather the signature of the addon is missing. The signature requirement was introduced in Firefox version 43.

@Bugsbane is not facing this issue but rather the signature of the addon is missing. The signature requirement was introduced in Firefox version 43.

@Bugsbane

This comment has been minimized.

Show comment
Hide comment
@Bugsbane

Bugsbane Jan 9, 2016

Make sure the about:config entry xpinstall.signatures.required is set to false or manually remove the addon and reinstall from here: https://addons.mozilla.org/firefox/addon/about-addons-memory/

Yes, I changed this, and it works fine for me now. Well, as expected at least I guess. My firefox is currently using 2.8gb of RAM according to the system and only 145mb according to this extension.

I'm guessing this falls under the "static or dynamic overlays that may add scripts, DOM or styles directly to the browser" caveat. The only extensions activated are:

Autoreload
Always right
"Dafault" by Mozilla (!?!!)
Kicktraq
Gnotifier
Adblock Edge
Disconnect
and of course about:addons-memory

Bugsbane commented Jan 9, 2016

Make sure the about:config entry xpinstall.signatures.required is set to false or manually remove the addon and reinstall from here: https://addons.mozilla.org/firefox/addon/about-addons-memory/

Yes, I changed this, and it works fine for me now. Well, as expected at least I guess. My firefox is currently using 2.8gb of RAM according to the system and only 145mb according to this extension.

I'm guessing this falls under the "static or dynamic overlays that may add scripts, DOM or styles directly to the browser" caveat. The only extensions activated are:

Autoreload
Always right
"Dafault" by Mozilla (!?!!)
Kicktraq
Gnotifier
Adblock Edge
Disconnect
and of course about:addons-memory

@jeffgrammer

This comment has been minimized.

Show comment
Hide comment
@jeffgrammer

jeffgrammer Jan 10, 2016

I just looked in to it again, and I noticed that replacing the loader.jsm with the one included in the ExtSDK's repo made navigating to about:addons-memory work, however, the page just indefinitely displays the loading screen. Also, navigating to chrome://about-addons-memory/content/about.xhtml with/without replacing the loader.jsm does the same as about:addons-memory, but does not work either. I'm not sure if this is specific to me, I have not tested on any other machines just yet, but it does not seem to be working. I will continue to look into this and keep you guys posted.

I just looked in to it again, and I noticed that replacing the loader.jsm with the one included in the ExtSDK's repo made navigating to about:addons-memory work, however, the page just indefinitely displays the loading screen. Also, navigating to chrome://about-addons-memory/content/about.xhtml with/without replacing the loader.jsm does the same as about:addons-memory, but does not work either. I'm not sure if this is specific to me, I have not tested on any other machines just yet, but it does not seem to be working. I will continue to look into this and keep you guys posted.

@jdorenbush

This comment has been minimized.

Show comment
Hide comment
@jdorenbush

jdorenbush Feb 5, 2016

I tried setting xpinstall.signatures.required to false and reinstalling the add-on. Neither solution worked for me.

Firefox 44.0

I tried setting xpinstall.signatures.required to false and reinstalling the add-on. Neither solution worked for me.

Firefox 44.0

@jeffgrammer

This comment has been minimized.

Show comment
Hide comment
@jeffgrammer

jeffgrammer Feb 5, 2016

@jdorenbush I believe the issue is with changes made in FF 44, there was a post made on the Firefox Addon Blog that addresses this. https://blog.mozilla.org/addons/2015/10/14/breaking-changes-let-const-firefox-nightly-44/

@jdorenbush I believe the issue is with changes made in FF 44, there was a post made on the Firefox Addon Blog that addresses this. https://blog.mozilla.org/addons/2015/10/14/breaking-changes-let-const-firefox-nightly-44/

@jcosentino

This comment has been minimized.

Show comment
Hide comment
@jcosentino

jcosentino Feb 15, 2016

I an on x64 Firefox 44.0.2 on Arch Linux, and the about:addons-memory page no longer works. It gives an error like when you use about:somethingnotthere

I an on x64 Firefox 44.0.2 on Arch Linux, and the about:addons-memory page no longer works. It gives an error like when you use about:somethingnotthere

@edouard-lopez

This comment has been minimized.

Show comment
Hide comment
@edouard-lopez

edouard-lopez Feb 17, 2016

@nmaier there is a pull request waiting to solve this issue.
Could you update this thread when you review and merge it?

@nmaier there is a pull request waiting to solve this issue.
Could you update this thread when you review and merge it?

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Feb 18, 2016

@edouard-lopez

You can simply use github extension installer then browse the pull request here and install the working version.

Do note: For firefox you will likely have to set xpinstall.signatures.required to False as the addon will be unsigned.

@edouard-lopez

You can simply use github extension installer then browse the pull request here and install the working version.

Do note: For firefox you will likely have to set xpinstall.signatures.required to False as the addon will be unsigned.

@edouard-lopez

This comment has been minimized.

Show comment
Hide comment
@edouard-lopez

edouard-lopez Feb 18, 2016

@InternalError503 Thanks. However, the extension just link to a .zip file not an .xpi

@InternalError503 Thanks. However, the extension just link to a .zip file not an .xpi

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Feb 18, 2016

@edouard-lopez

You need to install the addon and if you have the page open refresh it see the attached image.

sbydbf287ybysbdfb

The button highlighted in red should appear.

@edouard-lopez

You need to install the addon and if you have the page open refresh it see the attached image.

sbydbf287ybysbdfb

The button highlighted in red should appear.

@paulderdash

This comment has been minimized.

Show comment
Hide comment
@paulderdash

paulderdash Feb 28, 2016

Tried installing with Github Extension Installer. Installed but still does not work.
Nils - please fix this, invaluable for memory troubleshooting.

Tried installing with Github Extension Installer. Installed but still does not work.
Nils - please fix this, invaluable for memory troubleshooting.

@wadkar

This comment has been minimized.

Show comment
Hide comment
@wadkar

wadkar Mar 19, 2016

@InternalError503 thanks, I got it working.
@nmaier what can we do to help merge #23 ? Do we need some test or something?

wadkar commented Mar 19, 2016

@InternalError503 thanks, I got it working.
@nmaier what can we do to help merge #23 ? Do we need some test or something?

@paulderdash

This comment has been minimized.

Show comment
Hide comment
@paulderdash

paulderdash Mar 20, 2016

Wish I could get it working :(
Github Extension Installer tells me it installs after I 'Add to Firefox'. But there is still no addons:about-memory page, even after a FF restart..
@wadkar - was there anything else you did?
My FF memory usage has increased dramatically, trying to track down which add-on is causing this.
Unless it's due to switching from FF 32-bit to 64-bit version.

Wish I could get it working :(
Github Extension Installer tells me it installs after I 'Add to Firefox'. But there is still no addons:about-memory page, even after a FF restart..
@wadkar - was there anything else you did?
My FF memory usage has increased dramatically, trying to track down which add-on is causing this.
Unless it's due to switching from FF 32-bit to 64-bit version.

@wadkar

This comment has been minimized.

Show comment
Hide comment
@wadkar

wadkar Mar 20, 2016

Sorry, nothing special besides installing the github extension installer, setting xpinstall.signatures.required=false in firefox and well, yeah thats it.

wadkar commented Mar 20, 2016

Sorry, nothing special besides installing the github extension installer, setting xpinstall.signatures.required=false in firefox and well, yeah thats it.

@Holguitar

This comment has been minimized.

Show comment
Hide comment
@Holguitar

Holguitar Mar 27, 2016

Confirm what @wadkar said, github extension installer and downloading latest version did the job.
Beside the known about:config setting.

Confirm what @wadkar said, github extension installer and downloading latest version did the job.
Beside the known about:config setting.

@Arthur-BDR

This comment has been minimized.

Show comment
Hide comment
@Arthur-BDR

Arthur-BDR Apr 4, 2016

Hi, thanks for all the pointers. I installed successfully the github-extension-installer, and then clicked on the 'Add To Firefox' button for the nmaier/about-addons-memory addon, and it was still spinning at 'Installing...' overnight on a top-configuration system of mine (tried that since it was also spinning on lower ones).

In an attempt for an alternative route, I'm able to click on 'Download' button next to it and get it, but it seems to be a source set and I'm not sure what it needs to compile and install (while pretty techie, I'm not a github guru).

It seems to have worked for @Glimpf 8 days ago. Though compared to @InternalError503 's Feb 18 post picture, the repository is different (e.g. it shows branch 'Tree: 9c...' and I'm seeing 'Branch: master', etc.)

My Firefox version is 45.0.1 (seems to be latest as of right now), and the system is running Windows 10 64-bit. (Which might also be different from the successful install above.)

Any ideas what might be going wrong, or anything else I can try?

Thanks.

Hi, thanks for all the pointers. I installed successfully the github-extension-installer, and then clicked on the 'Add To Firefox' button for the nmaier/about-addons-memory addon, and it was still spinning at 'Installing...' overnight on a top-configuration system of mine (tried that since it was also spinning on lower ones).

In an attempt for an alternative route, I'm able to click on 'Download' button next to it and get it, but it seems to be a source set and I'm not sure what it needs to compile and install (while pretty techie, I'm not a github guru).

It seems to have worked for @Glimpf 8 days ago. Though compared to @InternalError503 's Feb 18 post picture, the repository is different (e.g. it shows branch 'Tree: 9c...' and I'm seeing 'Branch: master', etc.)

My Firefox version is 45.0.1 (seems to be latest as of right now), and the system is running Windows 10 64-bit. (Which might also be different from the successful install above.)

Any ideas what might be going wrong, or anything else I can try?

Thanks.

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Apr 6, 2016

For people who are having difficulties reading, Following or understanding the following posts in this ticket by me sorry about that, See below for a simplified option.

Original posts:

#21 (comment)
#21 (comment)

Here is the direct link to the test XPI file from pull request

Download

For people who are having difficulties reading, Following or understanding the following posts in this ticket by me sorry about that, See below for a simplified option.

Original posts:

#21 (comment)
#21 (comment)

Here is the direct link to the test XPI file from pull request

Download

@L0garithmic

This comment has been minimized.

Show comment
Hide comment
@L0garithmic

L0garithmic Apr 6, 2016

Submitted the fixed XPI to Firefox, they accepted. Thanks InternalError503!
https://addons.mozilla.org/en-US/firefox/addon/about-addons-memory-2016/

Submitted the fixed XPI to Firefox, they accepted. Thanks InternalError503!
https://addons.mozilla.org/en-US/firefox/addon/about-addons-memory-2016/

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Apr 22, 2016

Updated the XPI build in my local repository to support Firefox 48.0 and lower.

See comment for more information.
See all changes made here

Download

Updated the XPI build in my local repository to support Firefox 48.0 and lower.

See comment for more information.
See all changes made here

Download

@paulderdash

This comment has been minimized.

Show comment
Hide comment
@L0garithmic

This comment has been minimized.

Show comment
Hide comment
@L0garithmic

L0garithmic Apr 28, 2016

Submitted it, waiting on review.

Submitted it, waiting on review.

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 May 8, 2016

Updated the XPI build in my local repository to support Firefox 49.0a1 and lower.

See comment for more information.
See all changes made here

Download

Updated the XPI build in my local repository to support Firefox 49.0a1 and lower.

See comment for more information.
See all changes made here

Download

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 May 17, 2016

Updated the XPI build in my local repository to support Firefox 29.0 - 49.0a1

See comment for more information.
See all changes made here

Download

Updated the XPI build in my local repository to support Firefox 29.0 - 49.0a1

See comment for more information.
See all changes made here

Download

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 May 17, 2016

Updated the XPI build in my local repository to support Firefox 29.0 - 49.0a1

See comment for more information.
See all changes made here

Fixed: Issue with being able to open multiple about:addons-memory tabs.

Download

Updated the XPI build in my local repository to support Firefox 29.0 - 49.0a1

See comment for more information.
See all changes made here

Fixed: Issue with being able to open multiple about:addons-memory tabs.

Download

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 May 17, 2016

Updated the XPI build in my local repository to support Firefox 24.0 - 49.0a1

See comment for more information.
See all changes made here

Now works with Firefox 24.0 and up.
Note: Toolbar button only works from Firefox 29.0 and up.

Download

Updated the XPI build in my local repository to support Firefox 24.0 - 49.0a1

See comment for more information.
See all changes made here

Now works with Firefox 24.0 and up.
Note: Toolbar button only works from Firefox 29.0 and up.

Download

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Jun 1, 2016

Updated the XPI build in my local repository to support Firefox 24.0 - 49.0a1

See comment for more information.
See all changes made here

Now works with Firefox 24.0 and up.
Note: Toolbar button only works from Firefox 29.0 and up.

Download

@L0garithmic I see you have posted the builds to AMO, Please try this updated build and make sure to set the manifest support for the above 24.0 as minimum version.

Updated the XPI build in my local repository to support Firefox 24.0 - 49.0a1

See comment for more information.
See all changes made here

Now works with Firefox 24.0 and up.
Note: Toolbar button only works from Firefox 29.0 and up.

Download

@L0garithmic I see you have posted the builds to AMO, Please try this updated build and make sure to set the manifest support for the above 24.0 as minimum version.

@InternalError503

This comment has been minimized.

Show comment
Hide comment
@InternalError503

InternalError503 Jun 22, 2016

@L0garithmic Are you going to add the newer version of this with better compatibility posted here if not let me know and i will push it to AMO.

Thank you.

@L0garithmic Are you going to add the newer version of this with better compatibility posted here if not let me know and i will push it to AMO.

Thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment