Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NCAT SSL ERROR on 144 #1592

Closed
programme-zero opened this issue May 11, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@programme-zero
Copy link

commented May 11, 2019

Hello,
I'm trying to get a shell working between Windows and my other machine running on KDE plasma (up to date). The connection establishes and I get the shell, however executing a single command from my Linux machine to the Windows machine will provoke those errors and the connection ends up being lost
I read several issues here talking about a version error, but I believe to have installed the latest ncat version ( I got it from https://nmap.org/ncat/).
This is the output on the listener (Windows machine) :
NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: SSL error on 144: error:00000002:lib(0):func(0):system lib NCAT DEBUG: C:\Windows\system32>C
The errors never stop until I hit Ctrl + C.

The command line I used on the Windows machine : ncat --exec cmd.exe --allow 192.168.0.19 -vnl 4444 --ssl
The command line on the Linux machine : ncat -v 192.168.0.16 4444 --ssl
Thanks for your help.

@nnposter

This comment has been minimized.

Copy link

commented May 12, 2019

This appears to be a duplicate of #1267.

Published ncat 7.70 binaries predate a fix for this issue. If possible, please try to replicate the issue with ncat compiled from the current source code. (FWIW, I have not experienced these errors with newer ncat.)

@nnposter nnposter closed this May 19, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.