Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NPCAP - Breaks connection over mobile net adapter (DW5811a Snapdragon X7 LTE) #1651

Open
sgel83 opened this issue Jul 2, 2019 · 4 comments

Comments

Projects
None yet
3 participants
@sgel83
Copy link

commented Jul 2, 2019

After installing Wireshark with NPCAP 0.992 on Windows 10, my mobile network adapater no longer has internet access.

Interestingly, it gets an IP, it sets up routes, but you cannot ping even the other side of the tunnel. Ping returns a General failure.

Removing NPCAP and restarting the computer fixes it.

Unchecking NPCAP in the connection properties of the adapter has no affect, a full uninstall needs to happen.

What diagnostics would be usefull here?

@dmiller-nmap

This comment has been minimized.

Copy link

commented Jul 3, 2019

Thanks for the report! We're tracking a similar problem with a Sierra Wireless mobile adapter over at #1497, and we've gotten a report on Twitter as well. In that case, reinstalling Npcap without the loopback adapter was sufficient to solve the problem. Does this solve it for you as well?

We are investigating alternative methods of providing loopback capture and injection support that do not involve an adapter, since this has been a source of many problems. In the case of mobile adapters, I believe it has to do with routing metrics, but manually setting high metrics for the Npcap Loopback Adapter does not fix the issue; Windows may be doing something "smart" to prefer non-metered connections.

@sgel83

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

@dmiller-nmap - this is exactly the same problem and the same card. I will reinstall and get some diagnostics for you.

@sgel83

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

@dmiller-nmap

Diags are attached.

The work around does not work, if you just go into the Mobile Adapter Properties and uncheck either or both NCAP drivers the failure still exists. If you disable the NPCAP Loopback adapter it will work.

DiagReport-20190704-112136.txt

Let me know if there is anything else I can do to help you further.

@monofox

This comment has been minimized.

Copy link

commented Jul 20, 2019

Same issue on Windows 10 Enterprise, Version 1903 with a Fibocom L830-EB
DiagReport-20190720-180825.txt

Disabling "Npcap Packet Driver (NPCAP)" for the cellular network adapter is not enough. As @sgel83 mentioned, it is necessary to completely disable the loopback adapter.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.