Support openssl 1.1.0 without compatibility mode #630

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

eroen commented Jan 5, 2017

Currently, the built fails if openssl 1.1.0 is built with --api=1.1. These
changes remedy that.

  • Don't use deprecated initialization functions
  • Replace X509_get_notBefore and X509_get_notAfter with variants returning
    const objects
  • Include a few missing openssl headers

X-Gentoo-Bug: 592490
X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=592490

@eroen eroen Support openssl 1.1.0 without compatibility mode
Currently, the built fails if openssl 1.1.0 is built with --api=1.1. These
changes remedy that.

- Don't use deprecated initialization functions
- Replace X509_get_notBefore and X509_get_notAfter with variants returning
  const objects
- Include a few missing openssl headers

X-Gentoo-Bug: 592490
X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=592490
349a8e9

@eroen Thanks for doing this! I wasn't aware of the --api config switch. I applied this in r36533. If you have a real name you would like to be credited in the CHANGELOG, please let me know.

nmap-bot closed this in 9b86dad Jan 11, 2017

@suraj51k suraj51k added a commit to suraj51k/nmap that referenced this pull request Jan 31, 2017

@bonsaiviking @suraj51k bonsaiviking + suraj51k Remove deprecated calls from OpenSSL 1.1 API. Closes #630 a4e229f
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment