Drill down: empty grid when data source is an array of objects #19

Closed
nnajm opened this Issue Mar 27, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@nnajm
Owner

nnajm commented Mar 27, 2015

No description provided.

@nnajm nnajm added the bug label Mar 27, 2015

@nnajm nnajm self-assigned this Mar 27, 2015

@nnajm nnajm added this to the v1.0.9 milestone Mar 27, 2015

@ValentinH

This comment has been minimized.

Show comment
Hide comment
@ValentinH

ValentinH Mar 27, 2015

I was writing the same issue exactly in the same time! I provided a patch in a pull request for it... ;)

Here's the content of my issue report:

In the example, the drill-down works correctly but in my case, I use a datasource which consists in an array of objects and the drill-down grid is always empty.

I have noticed that this line is the source of the problem because it iterates on data[i].length while data[i] is an object.

If I replace it by:

for(var j in data[i]) {

it works for array of arrays and array of objects.

I was writing the same issue exactly in the same time! I provided a patch in a pull request for it... ;)

Here's the content of my issue report:

In the example, the drill-down works correctly but in my case, I use a datasource which consists in an array of objects and the drill-down grid is always empty.

I have noticed that this line is the source of the problem because it iterates on data[i].length while data[i] is an object.

If I replace it by:

for(var j in data[i]) {

it works for array of arrays and array of objects.

This was referenced Mar 27, 2015

@nnajm

This comment has been minimized.

Show comment
Hide comment
@nnajm

nnajm Jun 28, 2015

Owner

👍

Owner

nnajm commented Jun 28, 2015

👍

@nnajm nnajm closed this Jun 28, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment