Permalink
Browse files

Bump to 0.1.1, document support for redis versions and changelog

  • Loading branch information...
1 parent 2c0e6c8 commit 259c86777f34501e9b966b9e471b5c92b4cb32d5 @noahhl committed Jun 11, 2012
Showing with 15 additions and 2 deletions.
  1. +11 −0 CHANGELOG
  2. +3 −1 README.md
  3. +1 −1 lib/batsd.rb
View
@@ -0,0 +1,11 @@
+v0.1.1 - 2012-06-11
++ Feature: Support Redis versions < 2.6 (Grzesiek Kolodziejczyk)
++ Feature: Warn and abort on unsupported Redis version; superceded by above (Luca Spiller)
++ Bug fix: Explicitly require socket for MRI (Grzesiek Kolodziejczyk)
++ Bug fix: Explicitly require yard (Grzesiek Kolodziejczyk)
++ Bug fix: Explicitly require json (Michael Coyne)
++ Docs: Fix copy-paste failure (Victor Martinez)
+
+
+v0.1.0 - 2012-05-28
+Initial release
View
@@ -32,7 +32,9 @@ inspired by [quasor](https://github.com/quasor/statsd).
### Installation
#### Pre-requisites
Batsd requires Ruby 1.9.2 or JRuby 1.6 or greater, and access to a Redis
-v2.6.0-rc3 or later instance.
+instance. Redis > 2.6.0-rc3 will enable the use of Redis scripting, which
+is preferred for performance reasons, but earlier versions are supported with
+a performance penalty.
git clone git://github.com/noahhl/batsd && cd batsd && bundle install
View
@@ -21,5 +21,5 @@
# to disk at different levels of aggregation.
module Batsd
# Current version of the daemon
- VERSION = "0.1.0"
+ VERSION = "0.1.1"
end

0 comments on commit 259c867

Please sign in to comment.