Gyp support for node 0.8.16, necessary on OS X 10.8 #56

Merged
merged 2 commits into from Feb 11, 2013

Projects

None yet

2 participants

Contributor
icing commented Jan 9, 2013

Building with node-waf is no longer working on OS X 10.8 since it
enforces the i386 architecture. It needs to be x86_64 instead.

See also: nodejs/node-v0.x-archive#3633

I removed the wscript and added a simple binding.gyp

With the way node-gyp invokes the compile, I had an array
assignment error in line 67 on pcap_binding.cc which I
also corrected.

This version records http traffic on OS X 10.8.2, tested with mnot's
hdrgrab tool.

@ujjwalt ujjwalt merged commit 2d4765f into node-pcap:master Feb 11, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment