Browse files

sax parsers: use expat, ltx, saxjs by default

  • Loading branch information...
1 parent 282ec12 commit 761bebce5847f4a2ff35b848577a68823151ba59 @astro astro committed Mar 23, 2012
Showing with 4 additions and 4 deletions.
  1. +2 −2 lib/index-browserify.js
  2. +1 −1 lib/parse.js
  3. +1 −1 package.json
View
4 lib/index-browserify.js
@@ -1,6 +1,6 @@
/* Cause browserify to bundle SAX parsers: */
-require('./sax_easysax');
-require('./sax_saxjs');
+//require('./sax_easysax');
+//require('./sax_saxjs');
require('./sax_ltx');
/* SHIM */
View
2 lib/parse.js
@@ -3,7 +3,7 @@ var util = require('util');
exports.availableSaxParsers = [];
exports.bestSaxParser = null;
-['./sax_ltx.js', './sax_expat.js', /*'./sax_easysax.js',*/ /*'./sax_node-xml.js',*/ './sax_saxjs.js'].forEach(function(modName) {
+['./sax_expat.js', './sax_ltx.js', /*'./sax_easysax.js', './sax_node-xml.js',*/ './sax_saxjs.js'].forEach(function(modName) {
var mod;
try {
mod = require(modName);
View
2 package.json
@@ -5,6 +5,7 @@
,"description": "<xml for=\"node.js\">"
,"author": "Stephan Maka"
,"dependencies": {"node-expat": ">=1.2.0"
+ ,"sax": ">=0.3.5"
}
,"repositories": [{"type": "git"
,"path": "http://github.com/astro/ltx.git"
@@ -21,7 +22,6 @@
,"devDependencies": {"vows": ">=0.5.12"
,"easysax": ">=0.1.7"
,"node-xml": ">=1.0.1"
- ,"sax": ">=0.3.5"
,"Strophe.js": "https://github.com/metajack/strophejs/tarball/master"
,"request-animation-frame": ">=0.1.0"
}

0 comments on commit 761bebc

Please sign in to comment.