Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Build script doesn't check for libexpat #15

Closed
msiebuhr opened this Issue · 7 comments

3 participants

Morten Siebuhr Astro Camilo Aguilar
Morten Siebuhr

When installing node-expat, it doesn't check for the existence of the underlying C library (libexpat1-dev on Debian/Ubuntu).

Astro
Owner

How to check in a platform agnostic way?

Camilo Aguilar

pkg-config ? take a look at node-inotify in src/wscript

Camilo Aguilar

Sorry it is node-libvirt github.com/c4milo/node-libvirt/src/wscript

Camilo Aguilar

I just checked it, it seems like libexpat doesn't support pkg-config, that's a bummer.

Astro
Owner

Are you able to summon some autoconf magic?

Apologies for my delayed response, I'm currently on holiday.

Camilo Aguilar

I'm a little busy right now, but I'll try to make some time to look into it. there must exists someway to do it with python-waf.

Camilo Aguilar c4milo referenced this issue from a commit in c4milo/node-expat
Camilo Aguilar c4milo closes issue #15 1da0cd5
Astro
Owner

closed by @c4milo in 1da0cd5

Astro astro closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.