NPM install is failing when attempting to install node-expat #33

Closed
treffynnon opened this Issue Sep 14, 2011 · 1 comment

Comments

Projects
None yet
1 participant

I am seeing the following message back from NPM:

simon@simon-ubuntu64:~ $ sudo npm install node-xmpp

> node-expat@1.4.0 install /home/simon/node_modules/node-xmpp/node_modules/node-expat
> node-waf configure build

Checking for program g++ or c++          : /usr/bin/g++ 
Checking for program cpp                 : /usr/bin/cpp 
Checking for program ar                  : /usr/bin/ar 
Checking for program ranlib              : /usr/bin/ranlib 
Checking for g++                         : ok  
Checking for node path                   : not found 
Checking for node prefix                 : ok /usr 
Checking for header expat.h              : not installed 
/home/simon/node_modules/node-xmpp/node_modules/node-expat/wscript:13: error: the configuration failed (see '/home/simon/node_modules/node-xmpp/node_modules/node-expat/build/config.log')
npm ERR! error installing node-expat@1.4.0 Error: node-expat@1.4.0 install: `node-waf configure build`
npm ERR! error installing node-expat@1.4.0 `sh "-c" "node-waf configure build"` failed with 1
npm ERR! error installing node-expat@1.4.0     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing node-expat@1.4.0     at ChildProcess.emit (events.js:67:17)
npm ERR! error installing node-expat@1.4.0     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! error installing node-xmpp@0.2.10 Error: node-expat@1.4.0 install: `node-waf configure build`
npm ERR! error installing node-xmpp@0.2.10 `sh "-c" "node-waf configure build"` failed with 1
npm ERR! error installing node-xmpp@0.2.10     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing node-xmpp@0.2.10     at ChildProcess.emit (events.js:67:17)
npm ERR! error installing node-xmpp@0.2.10     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! node-expat@1.4.0 install: `node-waf configure build`
npm ERR! `sh "-c" "node-waf configure build"` failed with 1
npm ERR! 
npm ERR! Failed at the node-expat@1.4.0 install script.
npm ERR! This is most likely a problem with the node-expat package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-waf configure build
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-expat
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System Linux 2.6.38-11-generic
npm ERR! command "node" "/usr/bin/npm" "install" "node-xmpp"
npm ERR! cwd /home/simon
npm ERR! node -v v0.4.11
npm ERR! npm -v 1.0.27
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/simon/npm-debug.log
npm not ok

The file /home/simon/node_modules/node-xmpp/node_modules/node-expat/build/config.log is empty so I am not sure where to go from here.

OK so I have found an answer sudo apt-get install libexpat1-dev to get the library that node-expat depends upon. This was mentioned in a ticket here: cliftonc/calipso#25

Strange that I didn't encounter this when installing on a very similar Ubuntu machine. I suppose other OS package must have depended upon libeexpat and installed it before.

Anyway this is a non-issue so I am closing.

treffynnon closed this Sep 14, 2011

jessecravens referenced this issue in jessecravens/responderjs-fnresponsive-demo Nov 20, 2012

Open

npm ERR! Failed at the node-expat@1.4.1 install script. #1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment