Skip to content

jitsu databases - several errors. #289

Closed
edwardhotchkiss opened this Issue Jul 27, 2012 · 4 comments

3 participants

@edwardhotchkiss

tools w/ version:

Node.js: v0.8.0
Jitsu: 0.9.5


Broken Command:

jitsu databases list

result:

info:    Welcome to Nodejitsu edwardhotchkiss
info:    It worked if it ends with Nodejitsu ok
info:    Executing command databases list

/usr/local/lib/node_modules/jitsu/lib/jitsu/commands/databases.js:181
      results.forEach(function (database) {
              ^
TypeError: Object #<Object> has no method 'forEach'
    at databases.list (/usr/local/lib/node_modules/jitsu/lib/jitsu/commands/databases.js:181:15)
    at Databases.list (/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/lib/client/databases.js:56:5)
    at Request.Client.request [as _callback] (/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/lib/client/client.js:109:5)
    at Request.request.self.callback (/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/request/main.js:104:22)
    at Request.<anonymous> (/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/request/main.js:458:18)
    at Request.EventEmitter.emit (events.js:88:17)
    at IncomingMessage.Request.request.self.start.self.req.self.httpModule.request.buffer (/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/request/main.js:423:16)
    at IncomingMessage.EventEmitter.emit (events.js:115:20)
    at IncomingMessage._emitEnd (http.js:366:10)
    aEdwards-MacBook-Air:bkln.me edward$ 

Broken Command:

$ jitsu databases create
info:    A new mongo has been created
info:    Database name: undefined
error:   Unknown database type: undefined
info:    Nodejitsu ok
@Marak
Marak commented Jul 27, 2012

Hrmm, I'm not getting any of those right now.

Can you try upgrading to the latest stable version of node? You are a few behind.

@edwardhotchkiss

Exact same ouput with v0.8.4. Also can't deploy app ...

@AvianFlu

if you npm ls -g | grep nodejitsu-api, your version of nodejitsu-api will probably be 0.3.0, and needs to be 0.3.1.

npm will miss dependency bumps when it updates someitmes - npm cache clean and a reinstall of jitsu should fix it.

@edwardhotchkiss

Awesome, thanks. I know that you guys are on the move to Joyent, so the API is a'changin'.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.