Skip to content

Can't install jitsu #300

Closed
jesseditson opened this Issue Aug 26, 2012 · 10 comments

3 participants

@jesseditson

Hey, I'm on OSX Lion on a Sandy Bridge i7 - Tried a jitsu deploy, and I get a 500 back from nodejitsu.

Trying to make sure I wasn't seeing a known issue or something, I figured I'd update to the latest jitsu. However, doing an npm install -g jitsu fails, giving the following errors:

npm ERR! Error: No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm ERR!     at installTargetsError (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:438:17)
npm ERR!     at next (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:415:44)
npm ERR!     at /Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:408:5
npm ERR!     at saved (/Users/jesseditson/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/Users/jesseditson/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:231:7)
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.17
npm ERR! npm -v 1.1.2
npm ERR! message No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm http GET https://registry.npmjs.org/utile/-/utile-0.1.3.tgz
npm http GET https://registry.npmjs.org/winston/-/winston-0.6.2.tgz

npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___director.npm/package/README.md'
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.17
npm ERR! npm -v 1.1.2
npm ERR! path /usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___director.npm/package/README.md
npm ERR! fstream_path /usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___director.npm/package/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! message ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___director.npm/package/README.md'
npm ERR! errno {}
npm ERR! fstream_stack Object.oncomplete (/Users/jesseditson/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:204:26)
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/jesseditson/Dropbox/Sites/GetWished/Wished/npm-debug.log
npm not ok

Seems as if the read dep is improperly defined somewhere, possibly something else as well.

Is the jitsu install supposed to work, or is this a current issue?

@jfhbrook

Hi jesse,

You need to update your version of node to 0.6.20 or 0.8.x. This is due to a bug in the "read" library which is interrelated to some changes/fixes in node.

Update node and this should go away. :)

@jfhbrook jfhbrook closed this Aug 26, 2012
@jesseditson

Thanks for the quick reply!

Installed latest v0.6 (node -v now says v0.6.21-pre), but the install now fails with a different error:

npm ERR! error installing prompt@0.2.6
npm http GET https://github.com/indexzero/read/tarball/refactor-optional-streams
npm http 304 https://registry.npmjs.org/utile
npm ERR! error installing wizard@0.0.1
npm http 304 https://registry.npmjs.org/winston
npm http GET https://registry.npmjs.org/revalidator/-/revalidator-0.1.2.tgz
npm http GET https://registry.npmjs.org/utile/-/utile-0.1.3.tgz
npm ERR! error installing jitsu@0.9.7
npm http GET https://registry.npmjs.org/winston/-/winston-0.6.2.tgz
npm http 200 https://registry.npmjs.org/wordwrap

npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___broadway.npm/package/test/plugins/log-test.js'
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.21-pre
npm ERR! npm -v 1.1.2
npm ERR! path /usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___broadway.npm/package/test/plugins/log-test.js
npm ERR! fstream_path /usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___broadway.npm/package/test/plugins/log-test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! message ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/flatiron/node_modules/___broadway.npm/package/test/plugins/log-test.js'
npm ERR! errno {}
npm ERR! fstream_stack Object.oncomplete (/Users/jesseditson/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:204:26)

npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/jitsu/node_modules/___npm.npm/package/node_modules/node-gyp/legacy/tools/gyp/buildbot/buildbot_run.py'
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.21-pre
npm ERR! npm -v 1.1.2
npm ERR! path /usr/local/lib/node_modules/jitsu/node_modules/___npm.npm/package/node_modules/node-gyp/legacy/tools/gyp/buildbot/buildbot_run.py
npm ERR! code ENOENT
npm ERR! message ENOENT, open '/usr/local/lib/node_modules/jitsu/node_modules/___npm.npm/package/node_modules/node-gyp/legacy/tools/gyp/buildbot/buildbot_run.py'
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/jesseditson/Dropbox/Sites/GetWished/Wished/npm-debug.log
npm not ok
@jfhbrook

Interesting! My guess is it's an npm cache error. Try running npm cache clean and see what that does for you.

@jesseditson

hmm, same error, different order this time:

npm ERR! error installing prompt@0.2.6
npm ERR! error installing wizard@0.0.1
npm ERR! error installing jitsu@0.9.7
npm http 200 https://registry.npmjs.org/revalidator
npm http 200 https://registry.npmjs.org/minimatch

npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/___request.npm/package/LICENSE'
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "-g" "jitsu"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.21-pre
npm ERR! npm -v 1.1.2
npm ERR! path /usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/___request.npm/package/LICENSE
npm ERR! fstream_path /usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/___request.npm/package/LICENSE
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! message ENOENT, lstat '/usr/local/lib/node_modules/jitsu/node_modules/nodejitsu-api/node_modules/___request.npm/package/LICENSE'
npm ERR! errno {}
npm ERR! fstream_stack Object.oncomplete (/Users/jesseditson/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:204:26)
npm http 200 https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/winston
npm http GET https://registry.npmjs.org/revalidator/-/revalidator-0.1.2.tgz
npm http GET https://registry.npmjs.org/minimatch/-/minimatch-0.2.6.tgz

npm ERR! Error: No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm ERR!     at installTargetsError (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:438:17)
npm ERR!     at next (/Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:415:44)
npm ERR!     at /Users/jesseditson/local/lib/node_modules/npm/lib/cache.js:408:5
npm ERR!     at saved (/Users/jesseditson/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/Users/jesseditson/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:231:7)
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 12.1.0
npm ERR! command "node" "/Users/jesseditson/local/bin/npm" "install" "-g" "jitsu"
npm ERR! cwd /Users/jesseditson/Dropbox/Sites/GetWished/Wished
npm ERR! node -v v0.6.21-pre
npm ERR! npm -v 1.1.2
npm ERR! message No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/jesseditson/Dropbox/Sites/GetWished/Wished/npm-debug.log
npm not ok

I'll clean everything up and try again - hopefully something stupid in my env.

@AvianFlu

rm -rf /usr/local/lib/node_modules/jitsu will probably help, or npm uninstall jitsu -g.

@jfhbrook

I'd also recommend running node -v as a sanity check.

@jesseditson

node -v says v0.6.21-pre - I had a path issue from an old node install, fixed that & removed old stuff and jitsu installed ok.

Still having trouble deploying, but it's a non-solaris dependency issue, I can fix that on my side.

Thanks for the help on Sunday!

@jfhbrook

No problem!

@jesseditson

oops, spoke a little too soon. Not directly related to the original topic, but I figure it'd keep mess down to keep it on this thread unless you'd like me to open elsewhere.

I cleaned up the non-solaris stuff, things appear to be going smoothly, then right after Starting app <appname>, I get:

error:   Error running command deploy
error:   socket hang up
help:    For help with this error contact Nodejitsu Support:
help:      webchat: <http://webchat.nodejitsu.com/>
help:          irc: <irc://chat.freenode.net/#nodejitsu>
help:        email: <support@nodejitsu.com>
help:    
help:      Copy and paste this output to a gist (http://gist.github.com/)
info:    Nodejitsu not ok
@jesseditson

Interesting. Ran again for sanity and it worked. Probably not worth hunting down the non-reproducable error.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.