Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Exit on node@0.9.x #393

Closed
indexzero opened this Issue Feb 20, 2013 · 3 comments

Comments

Projects
None yet
4 participants
Owner

indexzero commented Feb 20, 2013

We should forcibly exit when users are using unstable versions of node unless --force is specified which should also warn them that the version of node they are using is unsupported.

Member

3rd-Eden commented Feb 20, 2013

Might be better to check if the minor version is uneven instead of just doing it for 0.9.x. This way you cover all future unstable versions of node as well

Contributor

mmalecki commented Feb 23, 2013

This is a terrible idea. Please do not do this. I use node's master at a daily basis.

Contributor

jfhbrook commented Feb 23, 2013

Suggestion: Only print a gnarly warning and get rid of exiting. That way, the user is told that they're using an unsupported version of node but can still go for it if they want to, and when support gets copypasta with the obvious warning in it they can explain the situation to the user.

@mmalecki mmalecki closed this in d508046 Feb 25, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment