Skip to content

Error msg when using package.json w/o version #46

Closed
bmeck opened this Issue Jun 17, 2011 · 0 comments

1 participant

@bmeck
bmeck commented Jun 17, 2011

jitsu deploy on a package.json that does not have a version number, goes through most of the steps and then gives a bad error

info:   Welcome to Nodejitsu
info:   It worked if it ends with Nodejitsu ok
info:   Executing command deploy
info:   Authenticated as bmeck
info:   Analyzing your application dependencies in server.js

/home/bradley/Documents/nodejitsu/jitsu/lib/jitsu/package.js:378
    winston.silly('Local version: ' + pkg.version.magenta);
                                                 ^
TypeError: Cannot read property 'magenta' of undefined
    at Object.updateTarball (/home/bradley/Documents/nodejitsu/jitsu/lib/jitsu/package.js:378:50)
    at updateSnapshot (/home/bradley/Documents/nodejitsu/jitsu/lib/jitsu/commands/apps.js:90:19)
    at /home/bradley/Documents/nodejitsu/jitsu/lib/jitsu/package.js:230:74
    at /home/bradley/Documents/nodejitsu/jitsu/lib/jitsu/package.js:304:5
    at /home/bradley/Documents/nodejitsu/jitsu/node_modules/require-analyzer/lib/require-analyzer.js:64:14

we should be prompting this, and it is fixable

@bmeck bmeck was assigned Jun 17, 2011
@bmeck bmeck added a commit that referenced this issue Jun 27, 2011
@bmeck bmeck [fix] #46 should be using the final version of the package rather tha…
…n the original
c2c98a2
@bmeck bmeck closed this Jun 27, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.