Error when deploying #493

Closed
SrSol opened this Issue Feb 1, 2014 · 2 comments

Projects

None yet

2 participants

@SrSol
SrSol commented Feb 1, 2014

I'm getting errors when doing 'jitsu deploy' from within my project. This is the output:

info: Welcome to Nodejitsu srsol
info: jitsu v0.13.9, node v0.10.24
info: It worked if it ends with Nodejitsu ok
info: Executing command deploy
info: Analyzing application dependencies in node node_modules/grunt-cli/bin/grunt
info: Creating snapshot 0.1.2-1
info Uploading: [=============================] 100%
error: Error running command deploy
error: npm exited with code 1
error: npm installation failed, please double check your package.json dependencies
error: Nodejitsu Error (500): Internal Server Error
help: For help with this error contact Nodejitsu Support:
help: webchat: http://webchat.nodejitsu.com/
help: irc: irc://chat.freenode.net/#nodejitsu
help: email: support@nodejitsu.com
help:
help: Copy and paste this output to a gist (http://gist.github.com/)
info: Nodejitsu not ok

My package.json is:

{
"name": "mean",
"description": "MEAN - A Modern Stack: MongoDB, ExpressJS, AngularJS, NodeJS. (BONUS: Passport User Support).",
"version": "0.1.2-1",
"private": false,
"author": "Amos Haviv",
"repository": {
"type": "git",
"url": "https://github.com/linnovate/mean.git"
},
"engines": {
"node": "0.10.x",
"npm": "1.3.x"
},
"scripts": {
"start": "node node_modules/grunt-cli/bin/grunt",
"test": "node node_modules/grunt-cli/bin/grunt test",
"postinstall": "node node_modules/bower/bin/bower install"
},
"dependencies": {
"express": "~3.4.7",
"jade": "~1.1.5",
"mongoose": "3.8.3",
"connect-mongo": "~0.4.0",
"connect-flash": "~0.1.1",
"crypto": "0.0.3",
"passport": "~0.2.0",
"passport-local": "~0.1.6",
"passport-facebook": "~1.0.2",
"passport-twitter": "~1.0.2",
"passport-github": "~0.1.5",
"passport-google-oauth": "~0.1.5",
"passport-linkedin": "~0.1.3",
"lodash": "~2.4.1",
"view-helpers": "~0.1.4",
"mean-logger": "1.0.0",
"bower": "~1.2.8",
"grunt": "~0.4.2",
"grunt-cli": "~0.1.11",
"grunt-env": "~0.4.1",
"forever": "~0.10.11",
"karma-script-launcher": "~0.1.0",
"karma-chrome-launcher": "~0.1.2",
"karma-firefox-launcher": "~0.1.3",
"karma-html2js-preprocessor": "~0.1.0",
"karma-jasmine": "~0.1.5",
"karma-requirejs": "~0.2.1",
"should": "3.1.2",
"grunt-concurrent": "~0.4.2",
"grunt-karma": "~0.7.2",
"karma-coffee-preprocessor": "~0.1.2",
"supertest": "0.9.0",
"karma-phantomjs-launcher": "~0.1.1",
"grunt-mocha-test": "~0.8.1",
"grunt-contrib-jshint": "~0.8.0",
"grunt-nodemon": "0.2.0",
"grunt-contrib-watch": "~0.5.3",
"karma-coverage": "~0.1.4",
"karma": "~0.11.13"
},
"devDependencies": {
"supertest": "0.9.0",
"should": "3.1.2",
"grunt-contrib-watch": "0.5.3",
"grunt-contrib-jshint": "0.8.0",
"grunt-nodemon": "0.2.0",
"grunt-concurrent": "0.4.3",
"grunt-mocha-test": "0.8.2",
"karma-script-launcher": "~0.1.0",
"karma-chrome-launcher": "~0.1.0",
"karma-firefox-launcher": "~0.1.0",
"karma-html2js-preprocessor": "~0.1.0",
"karma-jasmine": "~0.1.3",
"karma-requirejs": "~0.2.1",
"karma-coffee-preprocessor": "~0.1.0",
"karma-phantomjs-launcher": "~0.1.0",
"karma": "~0.11.13",
"grunt-karma": "~0.7.2",
"karma-coverage": "~0.1.0"
},
"subdomain": "tona-dev"
}

My nodejitsu subdomain is:

http://tona-dev.nodejitsu.com

What could it be?

@julianduque
Contributor

Next time send an email to support@nodejitsu.com or join our irc channel at #Nodejitsu in Freenode.

This is for issues related to the tool jitsu.

Tip: Don't run grunt, karma and bower on production, build the package for production before deploy and use a start script like "node server.js"

@julianduque julianduque closed this Feb 3, 2014
@SrSol
SrSol commented Feb 4, 2014

Got it! Thanks a lot julianduque ñ_ñ

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment