Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Cannot proxy einaros/ws web-sockets #451

Open
verma opened this Issue Aug 18, 2013 · 3 comments

Comments

Projects
None yet
3 participants

verma commented Aug 18, 2013

I cannot seem to get einaros/ws websockets proxied. The example code I am using is here:

https://gist.github.com/verma/6259211

I have posted a question regarding this on stackoverflow as well.

http://stackoverflow.com/questions/18294586/proxying-websockets-through-node-http-proxy-doesnt-work

In this example when I connect directly to the websocket server, things seem to work fine (port 19000 instead of 9090).

rc1 commented Sep 11, 2013

I think I am having the same problem.

Did you try sending a message from ws as soon a new client is connected? In my case ws is registering a new client, but the browser (ws client) is not receiving the connection event. If I send a message from ws when a new client is detected the browser gets the event.

I am using node v0.10. It was working on v0.8 AFAIK.

rc1 commented Sep 11, 2013

Seems to be related #444

Contributor

yawnt commented Nov 7, 2013

hi!
we are in the process of refactoring node-http-proxy to make it compatible with 0.10.x. you should check out caronte and give it a go with that!
thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment