Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm does not support Node.js v10.15.2 #1877

Closed
aguilared opened this issue Apr 21, 2019 · 15 comments

Comments

@aguilared
Copy link

@aguilared aguilared commented Apr 21, 2019

info it worked if it ends with ok
1 warn npm npm does not support Node.js v10.15.2
2 warn npm You should probably upgrade to a newer version of node as we
3 warn npm can't make any promises that npm will work with this version.
4 warn npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
5 warn npm You can find the latest version at https://nodejs.org/
6 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'install', '-g', 'eslint' ]
7 info using npm@5.8.0
8 info using node@v10.15.2
9 verbose npm-session 64c32217b44a7927

@yathamravali

This comment has been minimized.

Copy link

@yathamravali yathamravali commented Apr 22, 2019

@aguilared

It looks like current installed npm is not compatible with Node.js version you are using. You’ll probably need to update your npm using npm install npm@latest -g. And looks like everything fine despite of warnings.

@aguilared aguilared closed this Apr 22, 2019
@aguilared

This comment has been minimized.

Copy link
Author

@aguilared aguilared commented Apr 22, 2019

Ready, Thanks yathamravali, execute:
npm install npm@latest -g

$ npm -v
6.9.0

@rafaelvalentimzup

This comment has been minimized.

Copy link

@rafaelvalentimzup rafaelvalentimzup commented Sep 10, 2019

I'd suggest to try install it from source by:
curl https://www.npmjs.com/install.sh | sudo sh

@Daniel-Griffiths

This comment has been minimized.

Copy link

@Daniel-Griffiths Daniel-Griffiths commented Sep 17, 2019

Thanks! yathamravali's suggestion worked for me 😄

@ferenczy

This comment has been minimized.

Copy link

@ferenczy ferenczy commented Oct 3, 2019

I have installed node.js and npm on Debian 10 without explicitly specifying the version:

apt-get install nodejs
apt-get install npm

I ended up with the node.js version 10.15.2 and npm 5.8.0. There are no other versions of either of two in Debian 10's repository anyway.

But I'm getting the "does not support" error now. I can probably somehow manage to hack a different version of one of those things into there I guess, but really Debian maintainers picked incompatible versions into their distribution?

@Pair5Studios

This comment has been minimized.

Copy link

@Pair5Studios Pair5Studios commented Oct 3, 2019

@ferenczy I had the same problem in Ubuntu 19.04. However after reloading my shell, it seems the solution suggested by @aguilared worked

@sitiojcb

This comment has been minimized.

Copy link

@sitiojcb sitiojcb commented Oct 15, 2019

Thanks rafaelvalentimzup, that worked for me. I'm on MXLinux 19.

@matinwd

This comment has been minimized.

Copy link

@matinwd matinwd commented Oct 19, 2019

@Pair5Studios i have the same problem on ubuntu 19.04. Did u find any way ?

@thesomeexp

This comment has been minimized.

Copy link

@thesomeexp thesomeexp commented Oct 20, 2019

@Pair5Studios i have the same problem on ubuntu 19.04. Did u find any way ?

i have the same problem on ubuntu 19.04. Did u find any way ?

I have installed node.js and npm on Debian 10 without explicitly specifying the version:

apt-get install nodejs
apt-get install npm

I ended up with the node.js version 10.15.2 and npm 5.8.0. There are no other versions of either of two in Debian 10's repository anyway.

But I'm getting the "does not support" error now. I can probably somehow manage to hack a different version of one of those things into there I guess, but really Debian maintainers picked incompatible versions into their distribution?

i have the same problem on Debian 10.1 Did u find any way ?

@nunoguerreiro

This comment has been minimized.

Copy link

@nunoguerreiro nunoguerreiro commented Oct 21, 2019

I'd suggest to try install it from source by:
curl https://www.npmjs.com/install.sh | sudo sh

worked for me.

@alisonjo315

This comment has been minimized.

Copy link

@alisonjo315 alisonjo315 commented Oct 23, 2019

Me too on ubuntu 19.04 (originally installed both via apt, without any version specifications) -- same "does not support" error. The suggestion from @yathamravali (make npm update itself to the latest version) cleared the error from me. Thanks, all!

@ggichure

This comment has been minimized.

Copy link

@ggichure ggichure commented Oct 30, 2019

I'd suggest to try install it from source by:
curl https://www.npmjs.com/install.sh | sudo sh

shows it worked ,but npm -v still is at 5.8.0 .

@HenGrP

This comment has been minimized.

Copy link

@HenGrP HenGrP commented Nov 14, 2019

Ready, Thanks yathamravali, execute:
npm install npm@latest -g

$ npm -v
6.9.0

Don't forget to close the shell and open it again

@zurieelrdz

This comment has been minimized.

Copy link

@zurieelrdz zurieelrdz commented Nov 15, 2019

@aguilared

It looks like current installed npm is not compatible with Node.js version you are using. You’ll probably need to update your npm using npm install npm@latest -g. And looks like everything fine despite of warnings.

Still working. ty

@david8dixon

This comment has been minimized.

Copy link

@david8dixon david8dixon commented Nov 16, 2019

@ferenczy I had the same problem in Ubuntu 19.04. However after reloading my shell, it seems the solution suggested by @aguilared worked

Same exact result for me on 19.0.4.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.