Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Merge branch 'v0.6.16-release' into v0.6

  • Loading branch information
isaacs committed Apr 30, 2012
2 parents db844b1 + a1d1939 commit 518d28c23a5b809ec252b3a5984611022c0036fd
Showing with 850 additions and 566 deletions.
  1. +2 −0 AUTHORS
  2. +30 −1 ChangeLog
  3. +1 −0 deps/npm/AUTHORS
  4. +20 −0 deps/npm/doc/cli/config.md
  5. +77 −48 deps/npm/doc/cli/install.md
  6. +1 −1 deps/npm/html/api/bin.html
  7. +1 −1 deps/npm/html/api/bugs.html
  8. +1 −1 deps/npm/html/api/commands.html
  9. +1 −1 deps/npm/html/api/config.html
  10. +1 −1 deps/npm/html/api/deprecate.html
  11. +1 −1 deps/npm/html/api/docs.html
  12. +1 −1 deps/npm/html/api/edit.html
  13. +1 −1 deps/npm/html/api/explore.html
  14. +1 −1 deps/npm/html/api/help-search.html
  15. +1 −1 deps/npm/html/api/init.html
  16. +1 −1 deps/npm/html/api/install.html
  17. +1 −1 deps/npm/html/api/link.html
  18. +1 −1 deps/npm/html/api/load.html
  19. +1 −1 deps/npm/html/api/ls.html
  20. +2 −2 deps/npm/html/api/npm.html
  21. +1 −1 deps/npm/html/api/outdated.html
  22. +1 −1 deps/npm/html/api/owner.html
  23. +1 −1 deps/npm/html/api/pack.html
  24. +1 −1 deps/npm/html/api/prefix.html
  25. +1 −1 deps/npm/html/api/prune.html
  26. +1 −1 deps/npm/html/api/publish.html
  27. +1 −1 deps/npm/html/api/rebuild.html
  28. +1 −1 deps/npm/html/api/restart.html
  29. +1 −1 deps/npm/html/api/root.html
  30. +1 −1 deps/npm/html/api/run-script.html
  31. +1 −1 deps/npm/html/api/search.html
  32. +1 −1 deps/npm/html/api/shrinkwrap.html
  33. +1 −1 deps/npm/html/api/start.html
  34. +1 −1 deps/npm/html/api/stop.html
  35. +1 −1 deps/npm/html/api/submodule.html
  36. +1 −1 deps/npm/html/api/tag.html
  37. +1 −1 deps/npm/html/api/test.html
  38. +1 −1 deps/npm/html/api/uninstall.html
  39. +1 −1 deps/npm/html/api/unpublish.html
  40. +1 −1 deps/npm/html/api/update.html
  41. +1 −1 deps/npm/html/api/version.html
  42. +1 −1 deps/npm/html/api/view.html
  43. +1 −1 deps/npm/html/api/whoami.html
  44. +1 −1 deps/npm/html/doc/README.html
  45. +1 −1 deps/npm/html/doc/adduser.html
  46. +1 −1 deps/npm/html/doc/bin.html
  47. +1 −1 deps/npm/html/doc/bugs.html
  48. +1 −1 deps/npm/html/doc/build.html
  49. +1 −1 deps/npm/html/doc/bundle.html
  50. +1 −1 deps/npm/html/doc/cache.html
  51. +1 −1 deps/npm/html/doc/changelog.html
  52. +1 −1 deps/npm/html/doc/coding-style.html
  53. +1 −1 deps/npm/html/doc/completion.html
  54. +18 −2 deps/npm/html/doc/config.html
  55. +1 −1 deps/npm/html/doc/deprecate.html
  56. +1 −1 deps/npm/html/doc/developers.html
  57. +1 −1 deps/npm/html/doc/disputes.html
  58. +1 −1 deps/npm/html/doc/docs.html
  59. +1 −1 deps/npm/html/doc/edit.html
  60. +1 −1 deps/npm/html/doc/explore.html
  61. +1 −1 deps/npm/html/doc/faq.html
  62. +1 −1 deps/npm/html/doc/folders.html
  63. +1 −1 deps/npm/html/doc/help-search.html
  64. +1 −1 deps/npm/html/doc/help.html
  65. +1 −1 deps/npm/html/doc/index.html
  66. +1 −1 deps/npm/html/doc/init.html
  67. +20 −23 deps/npm/html/doc/install.html
  68. +1 −1 deps/npm/html/doc/json.html
  69. +1 −1 deps/npm/html/doc/link.html
  70. +1 −1 deps/npm/html/doc/list.html
  71. +2 −2 deps/npm/html/doc/npm.html
  72. +1 −1 deps/npm/html/doc/outdated.html
  73. +1 −1 deps/npm/html/doc/owner.html
  74. +1 −1 deps/npm/html/doc/pack.html
  75. +1 −1 deps/npm/html/doc/prefix.html
  76. +1 −1 deps/npm/html/doc/prune.html
  77. +1 −1 deps/npm/html/doc/publish.html
  78. +1 −1 deps/npm/html/doc/rebuild.html
  79. +1 −1 deps/npm/html/doc/registry.html
  80. +1 −1 deps/npm/html/doc/removing-npm.html
  81. +1 −1 deps/npm/html/doc/restart.html
  82. +1 −1 deps/npm/html/doc/root.html
  83. +1 −1 deps/npm/html/doc/run-script.html
  84. +1 −1 deps/npm/html/doc/scripts.html
  85. +1 −1 deps/npm/html/doc/search.html
  86. +1 −1 deps/npm/html/doc/semver.html
  87. +1 −1 deps/npm/html/doc/shrinkwrap.html
  88. +1 −1 deps/npm/html/doc/star.html
  89. +1 −1 deps/npm/html/doc/start.html
  90. +1 −1 deps/npm/html/doc/stop.html
  91. +1 −1 deps/npm/html/doc/submodule.html
  92. +1 −1 deps/npm/html/doc/tag.html
  93. +1 −1 deps/npm/html/doc/test.html
  94. +1 −1 deps/npm/html/doc/uninstall.html
  95. +1 −1 deps/npm/html/doc/unpublish.html
  96. +1 −1 deps/npm/html/doc/update.html
  97. +1 −1 deps/npm/html/doc/version.html
  98. +1 −1 deps/npm/html/doc/view.html
  99. +1 −1 deps/npm/html/doc/whoami.html
  100. +12 −3 deps/npm/html/index.html
  101. BIN deps/npm/html/n-64.png
  102. BIN deps/npm/html/n-large.png
  103. BIN deps/npm/html/npm-16.png
  104. BIN deps/npm/html/npm-256-square.png
  105. BIN deps/npm/html/npm-256w.png
  106. BIN deps/npm/html/npm-64-square.png
  107. BIN deps/npm/html/npm-fin.png
  108. BIN deps/npm/html/npm-large.png
  109. BIN deps/npm/html/npm.png
  110. +14 −6 deps/npm/lib/install.js
  111. +18 −1 deps/npm/lib/npm.js
  112. +6 −0 deps/npm/lib/utils/config-defs.js
  113. +17 −2 deps/npm/lib/utils/exec.js
  114. +3 −0 deps/npm/lib/utils/read-installed.js
  115. +38 −0 deps/npm/man/man1/config.1
  116. +58 −32 deps/npm/man/man1/install.1
  117. +1 −1 deps/npm/man/man1/npm.1
  118. +1 −1 deps/npm/man/man3/npm.3
  119. +14 −2 deps/npm/node_modules/fstream-npm/fstream-npm.js
  120. +2 −2 deps/npm/node_modules/fstream-npm/node_modules/fstream-ignore/package.json
  121. +5 −5 deps/npm/node_modules/fstream-npm/package.json
  122. +24 −0 deps/npm/node_modules/node-gyp/LICENSE
  123. +67 −35 deps/npm/node_modules/node-gyp/bin/node-gyp.js
  124. +1 −0 deps/npm/node_modules/node-gyp/legacy/common.gypi
  125. +67 −35 deps/npm/node_modules/node-gyp/lib/build.js
  126. +3 −24 deps/npm/node_modules/node-gyp/lib/clean.js
  127. +74 −45 deps/npm/node_modules/node-gyp/lib/configure.js
  128. +61 −43 deps/npm/node_modules/node-gyp/lib/install.js
  129. +3 −6 deps/npm/node_modules/node-gyp/lib/list.js
  130. +44 −4 deps/npm/node_modules/node-gyp/lib/node-gyp.js
  131. +2 −5 deps/npm/node_modules/node-gyp/lib/remove.js
  132. +0 −61 deps/npm/node_modules/node-gyp/lib/util/asyncEmit.js
  133. +0 −48 deps/npm/node_modules/node-gyp/lib/util/hook.js
  134. +2 −2 deps/npm/node_modules/node-gyp/node_modules/ansi/package.json
  135. +2 −2 deps/npm/node_modules/node-gyp/node_modules/glob/package.json
  136. +7 −7 deps/npm/node_modules/node-gyp/package.json
  137. +3 −4 deps/npm/package.json
  138. +36 −19 doc/api/url.markdown
  139. +1 −1 src/node_version.h
  140. +2 −2 src/process_wrap.cc
@@ -272,3 +272,5 @@ tedsuo <ted@radicaldesigns.org>
Joshua Holbrook <josh.holbrook@gmail.com>
Rod Vagg <rod@vagg.org>
Bryan Cantrill <bryan@joyent.com>
lrn@chromium.org <lrn@chromium.org>
Dane Springmeyer <dane@dbsgeo.com>
@@ -1,4 +1,33 @@
2012.04.09 Version 0.6.15 (stable)
2012.04.30 Version 0.6.16 (stable)

* Upgrade V8 to 3.6.6.25

* Upgrade npm to 1.1.19

* Windows: add mappings for UV_ENOENT (Bert Belder)

* linux: add IN_MOVE_SELF to inotify event mask (Ben Noordhuis)

* unix: call pipe handle connection cb on accept() error (Ben Noordhuis)

* unix: handle EWOULDBLOCK (Ben Noordhuis)

* map EWOULDBLOCK to UV_EAGAIN (Ben Noordhuis)

* Map ENOMEM to UV_ENOMEM (isaacs)

* Child process: support the `gid` and `uid` options (Bert Belder)

* test: cluster: add worker death event test (Ben Noordhuis)

* typo in node_http_parser (isaacs)

* http_parser: Eat CRLF between requests, even on connection:close. (Ben Noordhuis)

* don't check return value of unsetenv (Ben Noordhuis)


2012.04.09 Version 0.6.15 (stable), f160a45b254e591eb33716311c92be533c6d86c4

* Update npm to 1.1.16

@@ -63,3 +63,4 @@ Adam Blackburn <regality@gmail.com>
Kris Windham <kriswindham@gmail.com>
Jens Grunert <jens.grunert@gmail.com>
Joost-Wim Boekesteijn <joost-wim@boekesteijn.nl>
Dalmais Maxence <github@maxired.fr>
@@ -115,6 +115,8 @@ The following shorthands are parsed on the command-line:
* `-l`: `--long`
* `-desc`: `--description`
* `-S`: `--save`
* `-D`: `--save-dev`
* `-O`: `--save-optional`
* `-y`: `--yes`
* `-n`: `--yes false`
* `ll` and `la` commands: `ls --long`
@@ -584,6 +586,24 @@ Save installed packages to a package.json file as dependencies.

Only works if there is already a package.json file present.

### save-dev

* Default: false
* Type: Boolean

Save installed packages to a package.json file as devDependencies.

Only works if there is already a package.json file present.

### save-optional

* Default: false
* Type: Boolean

Save installed packages to a package.json file as optionalDependencies.

Only works if there is already a package.json file present.

### searchopts

* Default: ""
@@ -7,10 +7,11 @@ npm-install(1) -- Install a package
npm install <tarball file>
npm install <tarball url>
npm install <folder>
npm install <name>
npm install <name> [--save|--save-dev|--save-optional]
npm install <name>@<tag>
npm install <name>@<version>
npm install <name>@<version range>
npm install <name>@<version range>

## DESCRIPTION

@@ -35,88 +36,116 @@ after packing it up into a tarball (b).


* `npm install` (in package directory, no arguments):
Install the dependencies in the local node_modules folder.

In global mode (ie, with `-g` or `--global` appended to the command),
it installs the current package context (ie, the current working
directory) as a global package.
Install the dependencies in the local node_modules folder.

In global mode (ie, with `-g` or `--global` appended to the command),
it installs the current package context (ie, the current working
directory) as a global package.


* `npm install <folder>`:
Install a package that is sitting in a folder on the filesystem.

Install a package that is sitting in a folder on the filesystem.

* `npm install <tarball file>`:
Install a package that is sitting on the filesystem. Note: if you just want
to link a dev directory into your npm root, you can do this more easily by
using `npm link`.

Example:
Install a package that is sitting on the filesystem. Note: if you just want
to link a dev directory into your npm root, you can do this more easily by
using `npm link`.

Example:

npm install ./package.tgz
npm install ./package.tgz

* `npm install <tarball url>`:
Fetch the tarball url, and then install it. In order to distinguish between
this and other options, the argument must start with "http://" or "https://"

Example:
Fetch the tarball url, and then install it. In order to distinguish between
this and other options, the argument must start with "http://" or "https://"

Example:

npm install https://github.com/indexzero/forever/tarball/v0.5.6

* `npm install <name> [--save|--save-dev|--save-optional]`:

Do a `<name>@<tag>` install, where `<tag>` is the "tag" config. (See
`npm-config(1)`.)

npm install https://github.com/indexzero/forever/tarball/v0.5.6
In most cases, this will install the latest version
of the module published on npm.

* `npm install <name>`:
Do a `<name>@<tag>` install, where `<tag>` is the "tag" config. (See
`npm-config(1)`)
Example:

Example:
npm install sax

npm install sax
`npm install` takes 3 exclusive, optional flags which save or update
the package version in your main package.json:

**Note**: If there is a file or folder named `<name>` in the current
working directory, then it will try to install that, and only try to
fetch the package by name if it is not valid.
* `--save`: Package will appear in your `dependencies`.

* `--save-dev`: Package will appear in your `devDependencies`.

* `--save-optional`: Package will appear in your `optionalDependencies`.

Examples:

npm install sax --save
npm install node-tap --save-dev
npm install dtrace-provider --save-optional


**Note**: If there is a file or folder named `<name>` in the current
working directory, then it will try to install that, and only try to
fetch the package by name if it is not valid.

* `npm install <name>@<tag>`:
Install the version of the package that is referenced by the specified tag.
If the tag does not exist in the registry data for that package, then this
will fail.

Example:
Install the version of the package that is referenced by the specified tag.
If the tag does not exist in the registry data for that package, then this
will fail.

Example:

npm install sax@latest
npm install sax@latest

* `npm install <name>@<version>`:
Install the specified version of the package. This will fail if the version
has not been published to the registry.

Example:
Install the specified version of the package. This will fail if the version
has not been published to the registry.

npm install sax@0.1.1
Example:

npm install sax@0.1.1

* `npm install <name>@<version range>`:
Install a version of the package matching the specified version range. This
will follow the same rules for resolving dependencies described in `npm-json(1)`.

Note that most version ranges must be put in quotes so that your shell will
treat it as a single argument.
Install a version of the package matching the specified version range. This
will follow the same rules for resolving dependencies described in `npm-json(1)`.

Note that most version ranges must be put in quotes so that your shell will
treat it as a single argument.

Example:
Example:

npm install sax@">=0.1.0 <0.2.0"
npm install sax@">=0.1.0 <0.2.0"

* `npm install <git remote url>`:

Install a package by cloning a git remote url. The format of the git
url is:
Install a package by cloning a git remote url. The format of the git
url is:

<protocol>://[<user>@]<hostname><separator><path>[#<commit-ish>]
<protocol>://[<user>@]<hostname><separator><path>[#<commit-ish>]

`<protocol>` is one of `git`, `git+ssh`, `git+http`, or
`git+https`. If no `<commit-ish>` is specified, then `master` is
used.
`<protocol>` is one of `git`, `git+ssh`, `git+http`, or
`git+https`. If no `<commit-ish>` is specified, then `master` is
used.

Examples:
Examples:

git+ssh://git@github.com:isaacs/npm.git#v1.0.27
git+https://isaacs@github.com/isaacs/npm.git
git://github.com/isaacs/npm.git#v1.0.27
git+ssh://git@github.com:isaacs/npm.git#v1.0.27
git+https://isaacs@github.com/isaacs/npm.git
git://github.com/isaacs/npm.git#v1.0.27

You may combine multiple arguments, and even multiple types of arguments.
For example:
@@ -19,7 +19,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This function should not be used programmatically. Instead, just refer
to the <code>npm.bin</code> member.</p>
</div>
<p id="footer">bin &mdash; npm@1.1.16</p>
<p id="footer">bin &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This command will launch a browser, so this command may not be the most
friendly for programmatic use.</p>
</div>
<p id="footer">bugs &mdash; npm@1.1.16</p>
<p id="footer">bugs &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -28,7 +28,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>

<ul><li><a href="../doc/index.html">index(1)</a></li></ul>
</div>
<p id="footer">commands &mdash; npm@1.1.16</p>
<p id="footer">commands &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -33,7 +33,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>

<ul><li><a href="../api/npm.html">npm(3)</a></li></ul>
</div>
<p id="footer">config &mdash; npm@1.1.16</p>
<p id="footer">config &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -30,7 +30,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>

<ul><li><a href="../api/publish.html">publish(3)</a></li><li><a href="../api/unpublish.html">unpublish(3)</a></li><li><a href="../doc/registry.html">registry(1)</a></li></ul>
</div>
<p id="footer">deprecate &mdash; npm@1.1.16</p>
<p id="footer">deprecate &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This command will launch a browser, so this command may not be the most
friendly for programmatic use.</p>
</div>
<p id="footer">docs &mdash; npm@1.1.16</p>
<p id="footer">docs &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -30,7 +30,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Since this command opens an editor in a new process, be careful about where
and how this is used.</p>
</div>
<p id="footer">edit &mdash; npm@1.1.16</p>
<p id="footer">edit &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -24,7 +24,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>

<p>The first element in the 'args' parameter must be a package name. After that is the optional command, which can be any number of strings. All of the strings will be combined into one, space-delimited command.</p>
</div>
<p id="footer">explore &mdash; npm@1.1.16</p>
<p id="footer">explore &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -32,7 +32,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>

<p>The silent parameter is not neccessary not used, but it may in the future.</p>
</div>
<p id="footer">help-search &mdash; npm@1.1.16</p>
<p id="footer">help-search &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -35,7 +35,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>

<p><a href="../doc/json.html">json(1)</a></p>
</div>
<p id="footer">init &mdash; npm@1.1.16</p>
<p id="footer">init &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Finally, 'callback' is a function that will be called when all packages have been
installed or when an error has been encountered.</p>
</div>
<p id="footer">install &mdash; npm@1.1.16</p>
<p id="footer">install &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -39,7 +39,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Now, any changes to the redis package will be reflected in
the package in the current working directory</p>
</div>
<p id="footer">link &mdash; npm@1.1.16</p>
<p id="footer">link &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -32,7 +32,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>

<p>For a list of all the available command-line configs, see <code>npm help config</code></p>
</div>
<p id="footer">load &mdash; npm@1.1.16</p>
<p id="footer">load &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -59,7 +59,7 @@ <h3 id="global">global</h3>
This means that if a submodule a same dependency as a parent module, then the
dependency will only be output once.</p>
</div>
<p id="footer">ls &mdash; npm@1.1.16</p>
<p id="footer">ls &mdash; npm@1.1.19</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")

0 comments on commit 518d28c

Please sign in to comment.
You can’t perform that action at this time.