This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Merge remote-tracking branch 'upstream/v0.10'

Conflicts:
	doc/blog/feature/streams2.md
  • Loading branch information...
tjfontaine committed Feb 14, 2014
2 parents e8df267 + 55543d3 commit 6b4f72b7ac95bf3ec100bb70e7f6552e9aa18d7e
Showing 510 changed files with 1,271 additions and 26,490 deletions.
View
@@ -159,36 +159,15 @@ apidoc_sources = $(wildcard doc/api/*.markdown)
apidocs = $(addprefix out/,$(apidoc_sources:.markdown=.html)) \
$(addprefix out/,$(apidoc_sources:.markdown=.json))
-apidoc_dirs = out/doc out/doc/api/ out/doc/api/assets out/doc/about out/doc/community out/doc/download out/doc/logos out/doc/images
+apidoc_dirs = out/doc out/doc/api/ out/doc/api/assets
apiassets = $(subst api_assets,api/assets,$(addprefix out/,$(wildcard doc/api_assets/*)))
-doc_images = $(addprefix out/,$(wildcard doc/images/* doc/*.jpg doc/*.png))
-
website_files = \
- out/doc/index.html \
- out/doc/v0.4_announcement.html \
- out/doc/cla.html \
out/doc/sh_main.js \
- out/doc/sh_javascript.min.js \
- out/doc/sh_vim-dark.css \
- out/doc/sh.css \
- out/doc/favicon.ico \
- out/doc/pipe.css \
- out/doc/about/index.html \
- out/doc/community/index.html \
- out/doc/download/index.html \
- out/doc/logos/index.html \
- out/doc/changelog.html \
- $(doc_images)
-
-doc: $(apidoc_dirs) $(website_files) $(apiassets) $(apidocs) tools/doc/ blog node
-
-blogclean:
- rm -rf out/blog
-
-blog: doc/blog out/Release/node tools/blog
- out/Release/node tools/blog/generate.js doc/blog/ out/blog/ doc/blog.html doc/rss.xml
+ out/doc/sh_javascript.min.js
+
+doc: $(apidoc_dirs) $(website_files) $(apiassets) $(apidocs) tools/doc/ node
$(apidoc_dirs):
mkdir -p $@
@@ -199,9 +178,6 @@ out/doc/api/assets/%: doc/api_assets/% out/doc/api/assets/
out/doc/changelog.html: ChangeLog doc/changelog-head.html doc/changelog-foot.html tools/build-changelog.sh node
bash tools/build-changelog.sh
-out/doc/%.html: doc/%.html node
- cat $< | sed -e 's|__VERSION__|'$(VERSION)'|g' > $@
-
out/doc/%: doc/%
cp -r $< $@
@@ -218,9 +194,6 @@ email.md: ChangeLog tools/email-footer.md
blog.html: email.md
cat $< | ./node tools/doc/node_modules/.bin/marked > $@
-blog-upload: blog
- rsync -r out/blog/ node@nodejs.org:~/web/nodejs.org/blog/
-
website-upload: doc
rsync -r out/doc/ node@nodejs.org:~/web/nodejs.org/
ssh node@nodejs.org '\
View
@@ -0,0 +1,5 @@
+## Before you submit a new issue
+
+* Check if there's a simple solution in the [Troubleshooting](https://github.com/npm/npm/wiki/Troubleshooting) wiki.
+* [Search for similar issues](https://github.com/npm/npm/search?q=Similar%20issues&type=Issues).
+* Ensure your new issue conforms to the [Contributing Guidelines](https://github.com/npm/npm/wiki/Contributing-Guidelines).
View
@@ -1,4 +1,4 @@
-Copyright (c) Isaac Z. Schlueter
+Copyright (c) npm, Inc. and Contributors
All rights reserved.
npm is released under the Artistic License 2.0.
@@ -214,7 +214,7 @@ ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
--------
-"Node.js" and "node" trademark Joyent, Inc. npm is not officially
+"Node.js" and "node" trademark Joyent, Inc. npm is not officially
part of the Node.js project, and is neither owned by nor
officially affiliated with Joyent, Inc.
View
@@ -220,7 +220,7 @@ If this concerns you, inspect the source before using packages.
When you find issues, please report them:
* web:
- <https://github.com/isaacs/npm/issues>
+ <https://github.com/npm/npm/issues>
* email:
<npm-@googlegroups.com>
@@ -146,9 +146,9 @@ after packing it up into a tarball (b).
Examples:
- git+ssh://git@github.com:isaacs/npm.git#v1.0.27
- git+https://isaacs@github.com/isaacs/npm.git
- git://github.com/isaacs/npm.git#v1.0.27
+ git+ssh://git@github.com:npm/npm.git#v1.0.27
+ git+https://isaacs@github.com/npm/npm.git
+ git://github.com/npm/npm.git#v1.0.27
You may combine multiple arguments, and even multiple types of arguments.
For example:
@@ -61,6 +61,12 @@ Show parseable output instead of tree view.
List packages in the global install prefix instead of in the current
project.
+### depth
+
+* Type: Int
+
+Max display depth of the dependency tree.
+
## SEE ALSO
* npm-config(1)
@@ -14,6 +14,43 @@ The resulting field 'wanted' shows the latest version according to the
version specified in the package.json, the field 'latest' the very latest
version of the package.
+## CONFIGURATION
+
+### json
+
+* Default: false
+* Type: Boolean
+
+Show information in JSON format.
+
+### long
+
+* Default: false
+* Type: Boolean
+
+Show extended information.
+
+### parseable
+
+* Default: false
+* Type: Boolean
+
+Show parseable output instead of tree view.
+
+### global
+
+* Default: false
+* Type: Boolean
+
+Check packages in the global install prefix instead of in the current
+project.
+
+### depth
+
+* Type: Int
+
+Max depth for checking dependency tree.
+
## SEE ALSO
* npm-update(1)
View
@@ -114,15 +114,15 @@ easily by doing `npm view npm contributors`.
If you would like to contribute, but don't know what to work on, check
the issues list or ask on the mailing list.
-* <http://github.com/isaacs/npm/issues>
+* <http://github.com/npm/npm/issues>
* <npm-@googlegroups.com>
## BUGS
When you find issues, please report them:
* web:
- <http://github.com/isaacs/npm/issues>
+ <http://github.com/npm/npm/issues>
* email:
<npm-@googlegroups.com>
@@ -257,7 +257,7 @@ Do it like this:
"repository" :
{ "type" : "git"
- , "url" : "http://github.com/isaacs/npm.git"
+ , "url" : "http://github.com/npm/npm.git"
}
"repository" :
@@ -133,7 +133,7 @@ string message to the callback. Stack traces are handy.
## Logging
-Logging is done using the [npmlog](https://github.com/isaacs/npmlog)
+Logging is done using the [npmlog](https://github.com/npm/npmlog)
utility.
Please clean up logs when they are no longer helpful. In particular,
@@ -401,7 +401,7 @@ The value `npm init` should use by default for the package author's homepage.
### init.license
-* Default: "BSD-2-Clause"
+* Default: "ISC"
* Type: String
The value `npm init` should use by default for the package license.
@@ -466,7 +466,7 @@ The default is "http", which shows http, warn, and error output.
* Type: Stream
This is the stream that is passed to the
-[npmlog](https://github.com/isaacs/npmlog) module at run time.
+[npmlog](https://github.com/npm/npmlog) module at run time.
It cannot be set from the command line, but if you are using npm
programmatically, you may wish to send logs to somewhere other than
@@ -315,12 +315,12 @@ in a web browser. This will also tell you if you are just unable to
access the internet for some reason.
If the registry IS down, let me know by emailing <i@izs.me> or posting
-an issue at <https://github.com/isaacs/npm/issues>. We'll have
+an issue at <https://github.com/npm/npm/issues>. We'll have
someone kick it or something.
## Why no namespaces?
-Please see this discussion: <https://github.com/isaacs/npm/issues/798>
+Please see this discussion: <https://github.com/npm/npm/issues/798>
tl;dr - It doesn't actually make things better, and can make them worse.
@@ -338,7 +338,7 @@ There is not sufficient need to impose namespace rules on everyone.
Post an issue on the github project:
-* <https://github.com/isaacs/npm/issues>
+* <https://github.com/npm/npm/issues>
## Why does npm hate me?
@@ -14,7 +14,7 @@ account information.
The official public npm registry is at <http://registry.npmjs.org/>. It
is powered by a CouchDB database at
<http://isaacs.iriscouch.com/registry>. The code for the couchapp is
-available at <http://github.com/isaacs/npmjs.org>. npm user accounts
+available at <http://github.com/npm/npmjs.org>. npm user accounts
are CouchDB users, stored in the <http://isaacs.iriscouch.com/_users>
database.
@@ -226,7 +226,7 @@ <h2 id="BUGS">BUGS</h2>
<p>When you find issues, please report them:</p>
<ul><li>web:
-<a href="https://github.com/isaacs/npm/issues">https://github.com/isaacs/npm/issues</a></li><li>email:
+<a href="https://github.com/npm/npm/issues">https://github.com/npm/npm/issues</a></li><li>email:
<a href="mailto:npm-@googlegroups.com">npm-@googlegroups.com</a></li></ul>
<p>Be sure to include <em>all</em> of the output from the npm command that didn&#39;t work
@@ -239,7 +239,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>
<ul><li><a href="cli/npm.html">npm(1)</a></li><li><a href="misc/npm-faq.html">npm-faq(7)</a></li><li><a href="cli/npm-help.html">npm-help(1)</a></li><li><a href="misc/npm-index.html">npm-index(7)</a></li></ul>
</div>
-<p id="footer"><a href="../doc/README.html">README</a> &mdash; npm@1.3.26</p>
+<p id="footer"><a href="../doc/README.html">README</a> &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -19,7 +19,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This function should not be used programmatically. Instead, just refer
to the <code>npm.bin</code> member.</p>
</div>
-<p id="footer">npm-bin &mdash; npm@1.3.26</p>
+<p id="footer">npm-bin &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This command will launch a browser, so this command may not be the most
friendly for programmatic use.</p>
</div>
-<p id="footer">npm-bugs &mdash; npm@1.3.26</p>
+<p id="footer">npm-bugs &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -28,7 +28,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>
<ul><li><a href="../misc/npm-index.html">npm-index(7)</a></li></ul>
</div>
-<p id="footer">npm-commands &mdash; npm@1.3.26</p>
+<p id="footer">npm-commands &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -33,7 +33,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>
<ul><li><a href="../api/npm.html">npm(3)</a></li></ul>
</div>
-<p id="footer">npm-config &mdash; npm@1.3.26</p>
+<p id="footer">npm-config &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -32,7 +32,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>
<ul><li><a href="../api/npm-publish.html">npm-publish(3)</a></li><li><a href="../api/npm-unpublish.html">npm-unpublish(3)</a></li><li><a href="../misc/npm-registry.html">npm-registry(7)</a></li></ul>
</div>
-<p id="footer">npm-deprecate &mdash; npm@1.3.26</p>
+<p id="footer">npm-deprecate &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>This command will launch a browser, so this command may not be the most
friendly for programmatic use.</p>
</div>
-<p id="footer">npm-docs &mdash; npm@1.3.26</p>
+<p id="footer">npm-docs &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -30,7 +30,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Since this command opens an editor in a new process, be careful about where
and how this is used.</p>
</div>
-<p id="footer">npm-edit &mdash; npm@1.3.26</p>
+<p id="footer">npm-edit &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -24,7 +24,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>The first element in the &#39;args&#39; parameter must be a package name. After that is the optional command, which can be any number of strings. All of the strings will be combined into one, space-delimited command.</p>
</div>
-<p id="footer">npm-explore &mdash; npm@1.3.26</p>
+<p id="footer">npm-explore &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -32,7 +32,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>The silent parameter is not neccessary not used, but it may in the future.</p>
</div>
-<p id="footer">npm-help-search &mdash; npm@1.3.26</p>
+<p id="footer">npm-help-search &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -35,7 +35,7 @@ <h2 id="SEE-ALSO">SEE ALSO</h2>
<p><a href="../files/package.json.html">package.json(5)</a></p>
</div>
-<p id="footer">npm-init &mdash; npm@1.3.26</p>
+<p id="footer">npm-init &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -25,7 +25,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Finally, &#39;callback&#39; is a function that will be called when all packages have been
installed or when an error has been encountered.</p>
</div>
-<p id="footer">npm-install &mdash; npm@1.3.26</p>
+<p id="footer">npm-install &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -39,7 +39,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>Now, any changes to the redis package will be reflected in
the package in the current working directory</p>
</div>
-<p id="footer">npm-link &mdash; npm@1.3.26</p>
+<p id="footer">npm-link &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -32,7 +32,7 @@ <h2 id="DESCRIPTION">DESCRIPTION</h2>
<p>For a list of all the available command-line configs, see <code>npm help config</code></p>
</div>
-<p id="footer">npm-load &mdash; npm@1.3.26</p>
+<p id="footer">npm-load &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
@@ -59,7 +59,7 @@ <h3 id="global">global</h3>
This means that if a submodule a same dependency as a parent module, then the
dependency will only be output once.</p>
</div>
-<p id="footer">npm-ls &mdash; npm@1.3.26</p>
+<p id="footer">npm-ls &mdash; npm@1.4.0</p>
<script>
;(function () {
var wrapper = document.getElementById("wrapper")
Oops, something went wrong.

0 comments on commit 6b4f72b

Please sign in to comment.