Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Can't install node using make install #2197

Closed
AndreasMadsen opened this Issue Nov 26, 2011 · 4 comments

Comments

Projects
None yet
3 participants
Member

AndreasMadsen commented Nov 26, 2011

@bnoordhuis

I just merged the v0.6 branch intro my own fork-repo, but now i cant install node, when using make install:

./configure --prefix=/Users/Andreas/node

make && make install
`make install` is not implemented yet. Bug bnoordhuis about it in #node.js

Previously i was building on 0.6.1-pre and it worked fine.

kiilo commented Nov 26, 2011

same issue here

`make install` is not implemented yet. Bug bnoordhuis about it in #node.js

just cloned it before.

Member

bnoordhuis commented Nov 26, 2011

@AndreasMadsen: You merged the master branch, not v0.6.

@bnoordhuis bnoordhuis closed this Nov 26, 2011

kiilo commented Nov 26, 2011

YES

in the IRC channel someone gave the right hint:

mmalecki 10:40:32
hahaha
kiilo: node is switching build systems, use v0.6.3 tag

ok in plain english
cd to your clone

check which tags are avaiable
git tag -l

clone the right tag (in this case v0.6.3)
git checkout v0.6.3

just for brevity i did a
make clean
./configure
make
sudo make install

Member

AndreasMadsen commented Nov 26, 2011

I'm dame sure that I did merge from v0.6, but apparently you are correct. I just did this:

git fetch upstream
git merge upstream/v0.6
make clean
./configure --prefix=/Users/Andreas/node
make && make install

and now it do work.
Thanks anyway.

ry added a commit that referenced this issue Dec 14, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment