Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

REPL output issue in v0.3.2 - v0.3.3-pre #543

Closed
tswicegood opened this Issue Jan 1, 2011 · 4 comments

Comments

Projects
None yet
2 participants

There appears to be an output issue in the REPL in the latest unstable version of Node (v0.3.2). The entire captured line is being outputted along with some bizarre formatting in the case of function declarations and such. You can see some of the output in this gist.

I've attempted re-compiling Node with both lib/repl.js and lib/readline.js reverted to their v0.3.1 state, but the problem persists. I've looked briefly at the diff from those and src/node_stdio.cc and src/node_buffer.cc and I don't see anything obvious in any of these that would cause a problem.

I'm happy to help debug/fix this if you can provide some guidance above and beyond what I've already done. Not sure where else I should be looking. I didn't see anything in lib/repl.js that should have caused this issue and recompiling with the old version seems to have bore that out.

Do I need to completely remove the old version or are there any special instructions beyond the standard make install to get a new version of the JS file in place when recompiling?

ry commented Jan 1, 2011

due to b57c1f5

ry commented Jan 2, 2011

fixed in 1c7cd4a

Sweet. Just confirmed it with my code from the Gist. Thanks!

@coolaj86 coolaj86 pushed a commit that referenced this issue Apr 15, 2011

@ry ry Make syntax error display optional
Fixes GH-543
1c7cd4a

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment