Support for TLS ALPN #5945

molnarg opened this Issue Jul 30, 2013 · 15 comments


None yet

10 participants


TLS Application Layer Protocol Negotiation Extension is a new standard designed to be an alternative to NPN. It will be used for negotiating HTTP2 over TLS. This ticket is meant to track progress of inclusion of ALPN in node.js.

AFAIK, this depends on OpenSSL to implement ALPN. There's a patch floating around for OpenSSL, but it's not merged yet.

Node.js Foundation member

I'm closing this as there's nothing actionable right now. Please holler or file a new issue when ALPN support lands in a stable openssl version. (Stress on the word 'stable'.)

@bnoordhuis bnoordhuis closed this Jul 30, 2013

Status update: support is landed in OpenSSL repo, but not released yet.

@molnarg molnarg referenced this issue in molnarg/node-http2 Aug 7, 2013

ALPN negotiation #5


Status update: Shigeki Ohtsu has an experimental node.js fork with ALPN support:


FYI: ALPN support landed in the recent 1.0.2 version release of openssl.


1.0.2 is stable release, so please reopen, this is an actionable bug now.


Not sure @bnoordhuis is gonna see this without an actual mention. 😜

Node.js Foundation member

Indeed I didn't. Reopening and cc @shigeki.

@bnoordhuis bnoordhuis reopened this Feb 26, 2015

I'm now working on upgrading openssl-1.0.2 at nodejs/node#589 . It will be finished soon and can also be applied to Node as far as I can see. Probably I think that it's not on 0.12 but the next version.




Great work on closing nodejs/node#589 @shigeki !
Looking forward to seeing openssl-1.0.2 and ALPN in node.js as well.


Adding to the 0.13.1 milestone, thank you @shigeki!

@misterdjules misterdjules added this to the 0.13.1 milestone May 4, 2015

Great to see there is some traction on this front - as we looking to start work building out out our platform with http2 support. @misterdjules to confirm this is being targeted in the 0.13.1 release of node.js? Is there a estimated release date?

Node.js Foundation member

@shigeki @misterdjules ... what's the current status on this one? Is this something we'll see land in v0.12.x at all or should we defer to the converged repo?


This cannot be landed in v0.12. This issue should be moved to iojs and converged repo that has openssl-1.0.2. I'm going to open a new issue or PR soon and refer here.

@shigeki shigeki closed this Jun 25, 2015

@shigeki please let us know what the new PR issue issue, as we are also keen on the ALPN support in node.js and would like to confirm that it is still on track for 0.13.1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment