Permalink
Browse files

deps: fix openssl assembly error on ia32 win32

`x86masm.pl` was mistakenly using .486 instruction set, why `cpuid` (and
perhaps others) are requiring .686 .

Fixes: #589
PR-URL: #1389
Reviewed-By: Fedor Indutny <fedor@indutny.com>
Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl>
Reviewed-By: Shigeki Ohtsu <ohtsu@iij.ad.jp>
  • Loading branch information...
1 parent 6c7bdf5 commit 24640f9278fc56d3a8c159b2ccb781c9e27efb25 @indutny indutny committed with Myles Borins Jan 8, 2014
Showing with 1 addition and 1 deletion.
  1. +1 −1 deps/openssl/openssl/crypto/perlasm/x86masm.pl
@@ -82,7 +82,7 @@ sub ::file
IF \@Version LT 800
ECHO MASM version 8.00 or later is strongly recommended.
ENDIF
-.486
+.686
.MODEL FLAT
OPTION DOTNAME
IF \@Version LT 800

0 comments on commit 24640f9

Please sign in to comment.