Permalink
Browse files

test: ensure npm version is not release candidate

v11.6.0 ended up shipping with an npm version `6.5.0-next.0`.
This test should avoid it happening in the future.

PR-URL: #25538
Reviewed-By: Richard Lau <riclau@uk.ibm.com>
Reviewed-By: Colin Ihrig <cjihrig@gmail.com>
Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de>
Reviewed-By: Michaël Zasso <targos@protonmail.com>
Reviewed-By: James M Snell <jasnell@gmail.com>
Reviewed-By: Minwoo Jung <minwoo@nodesource.com>
  • Loading branch information...
MylesBorins committed Jan 16, 2019
1 parent ed0da63 commit 2e613a9c301165d121b19b86e382860323abc22f
Showing with 18 additions and 0 deletions.
  1. +18 −0 test/parallel/test-npm-version.js
@@ -0,0 +1,18 @@
'use strict';
require('../common');

const path = require('path');
const assert = require('assert');

const npmPathPackageJson = path.resolve(
__dirname,
'..',
'..',
'deps',
'npm',
'package.json'
);

const pkg = require(npmPathPackageJson);
assert(pkg.version.match(/^\d+\.\d+\.\d+$/),
`unexpected version number: ${pkg.version}`);

0 comments on commit 2e613a9

Please sign in to comment.