Skip to content
Permalink
Browse files

tools: update tooling to work with new macOS CLI …

Using High Sierra and `xcode-select --install` without installing full
Xcode, our build tooling breaks due to faulty regular expressions.

Update the `configure` script in our project root directory to handle
multi-digit version numbers.

`tools/gyp` and `deps/npm/node_modules/node-gyp` still need to be
updated for a complete fix.

PR-URL: #21173
Reviewed-By: Richard Lau <riclau@uk.ibm.com>
Reviewed-By: Luigi Pinca <luigipinca@gmail.com>
Reviewed-By: Refael Ackermann <refack@gmail.com>
Reviewed-By: James M Snell <jasnell@gmail.com>
  • Loading branch information...
Trott committed Jun 8, 2018
1 parent a9e70d7 commit 400df22c6bfefc3c3f54ebd7c5fd0d38f5137841
Showing with 1 addition and 1 deletion.
  1. +1 −1 configure
@@ -667,7 +667,7 @@ def get_llvm_version(cc):

def get_xcode_version(cc):
return get_version_helper(
cc, r"(^Apple LLVM version) ([5-9]\.[0-9]+)")
cc, r"(^Apple LLVM version) ([0-9]+\.[0-9]+)")

def get_gas_version(cc):
try:

0 comments on commit 400df22

Please sign in to comment.
You can’t perform that action at this time.