Skip to content
Permalink
Browse files

2019-03-14, Version 11.12.0 (Current)

Notable Changes

* build:
  * Enable v8's siphash for hash seed creation (Rod Vagg)
    #26367
* deps:
  * Upgrade openssl to 1.1.1b (Sam Roberts)
    #26327
* process:
  * Make `process[Symbol.toStringTag]` writable again
    (Ruben Bridgewater) #26488
* repl:
  * Add `util.inspect.replDefaults` to customize the writer
    (Ruben Bridgewater) #26375
* report:
  * Rename `triggerReport()` to `writeReport()` (Colin Ihrig)
    #26527
  • Loading branch information...
BridgeAR committed Mar 13, 2019
1 parent f95e015 commit fe6644527f03608102315675205d801615dc1588
Showing with 176 additions and 14 deletions.
  1. +2 −1 CHANGELOG.md
  2. +1 −1 doc/api/cli.md
  3. +1 −1 doc/api/crypto.md
  4. +1 −1 doc/api/deprecations.md
  5. +1 −1 doc/api/errors.md
  6. +6 −6 doc/api/process.md
  7. +161 −0 doc/changelogs/CHANGELOG_V11.md
  8. +3 −3 src/node_version.h
@@ -28,7 +28,8 @@ release.
</tr>
<tr>
<td valign="top">
<b><a href="doc/changelogs/CHANGELOG_V11.md#11.11.0">11.11.0</a></b><br/>
<b><a href="doc/changelogs/CHANGELOG_V11.md#11.12.0">11.12.0</a></b><br/>
<a href="doc/changelogs/CHANGELOG_V11.md#11.11.0">11.11.0</a><br/>
<a href="doc/changelogs/CHANGELOG_V11.md#11.10.1">11.10.1</a><br/>
<a href="doc/changelogs/CHANGELOG_V11.md#11.10.0">11.10.0</a><br/>
<a href="doc/changelogs/CHANGELOG_V11.md#11.9.0">11.9.0</a><br/>
@@ -179,7 +179,7 @@ Force FIPS-compliant crypto on startup. (Cannot be disabled from script code.)

### `--frozen-intrinsics`
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

> Stability: 1 - Experimental
@@ -1125,7 +1125,7 @@ passing keys as strings or `Buffer`s due to improved security features.
<!-- YAML
added: v11.6.0
changes:
- version: REPLACEME
- version: v11.12.0
pr-url: https://github.com/nodejs/node/pull/26319
description: Added support for `'ed25519'` and `'ed448'`
-->
@@ -2110,7 +2110,7 @@ changes:
- version: v10.9.0
pr-url: https://github.com/nodejs/node/pull/22004
description: Documentation-only deprecation.
- version: REPLACEME
- version: v11.12.0
pr-url: https://github.com/nodejs/node/pull/26500
description: Added support for `--pending-deprecation`.
-->
@@ -1973,7 +1973,7 @@ A module file could not be resolved while attempting a [`require()`][] or
### ERR_CLOSED_MESSAGE_PORT
<!-- YAML
added: v10.5.0
removed: REPLACEME
removed: v11.12.0
-->

There was an attempt to use a `MessagePort` instance in a closed
@@ -1671,7 +1671,7 @@ reports for the current process. Additional documentation is available in the

### process.report.directory
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {string}
@@ -1686,7 +1686,7 @@ console.log(`Report directory is ${process.report.directory}`);

### process.report.filename
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {string}
@@ -1719,7 +1719,7 @@ Additional documentation is available in the [report documentation][].

### process.report.reportOnFatalError
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {boolean}
@@ -1733,7 +1733,7 @@ console.log(`Report on fatal error: ${process.report.reportOnFatalError}`);

### process.report.reportOnSignal
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {boolean}
@@ -1747,7 +1747,7 @@ console.log(`Report on signal: ${process.report.reportOnSignal}`);

### process.report.reportOnUncaughtException
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {boolean}
@@ -1760,7 +1760,7 @@ console.log(`Report on exception: ${process.report.reportOnUncaughtException}`);

### process.report.signal
<!-- YAML
added: REPLACEME
added: v11.12.0
-->

* {string}

Large diffs are not rendered by default.

Oops, something went wrong.
@@ -23,13 +23,13 @@
#define SRC_NODE_VERSION_H_

#define NODE_MAJOR_VERSION 11
#define NODE_MINOR_VERSION 11
#define NODE_PATCH_VERSION 1
#define NODE_MINOR_VERSION 12
#define NODE_PATCH_VERSION 0

#define NODE_VERSION_IS_LTS 0
#define NODE_VERSION_LTS_CODENAME ""

#define NODE_VERSION_IS_RELEASE 0
#define NODE_VERSION_IS_RELEASE 1

#ifndef NODE_STRINGIFY
#define NODE_STRINGIFY(n) NODE_STRINGIFY_HELPER(n)

0 comments on commit fe66445

Please sign in to comment.
You can’t perform that action at this time.