Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

deps: upgrade npm to 6.9.0 #26244

Closed
wants to merge 1 commit into from

Conversation

Projects
None yet
6 participants
@zkat
Copy link
Contributor

commented Feb 21, 2019

Checklist
  • make -j4 test (UNIX), or vcbuild test (Windows) passes
  • tests and/or benchmarks are included
  • documentation is changed or added
  • commit message follows commit guidelines
Where this should land
  • Node 11
  • Node 10
  • Node 8
Notable changes
Changelogs
@zkat

This comment has been minimized.

Copy link
Contributor Author

commented Feb 21, 2019

Trying out Draft PRs for this, since we're still in prerelease and the whole point of these PRs is for y'all to get a chance to review things earlier. #26208 is still applicable until this becomes latest.

@bricss bricss referenced this pull request Mar 8, 2019

Closed

deps: upgrade npm to 6.8.0 #26208

4 of 4 tasks complete
@BridgeAR

This comment has been minimized.

Copy link
Member

commented Apr 3, 2019

@zkat I believe 6.9 is out and includes the fix that blocks 6.8 from being included here, right?

@MylesBorins MylesBorins marked this pull request as ready for review Apr 5, 2019

@MylesBorins

This comment has been minimized.

Copy link
Member

commented Apr 5, 2019

I'm updating this right now

deps: upgrade npm to 6.9.0
Co-authored-by: Myles Borins <mylesborins@google.com>

@MylesBorins MylesBorins force-pushed the npm:npm-6.9.0 branch from bfbad1b to 93fd25d Apr 5, 2019

@MylesBorins
Copy link
Member

left a comment

I've updated this PR to be based on the released version of 6.9.0 PTAL

Only 2 test failures locally... same as previous updates

@BridgeAR
Copy link
Member

left a comment

RSLGTM

@MylesBorins

This comment has been minimized.

1 similar comment
@nodejs-github-bot

This comment has been minimized.

@MylesBorins

This comment has been minimized.

Copy link
Member

commented Apr 7, 2019

landed in 033f6b5

@MylesBorins MylesBorins closed this Apr 7, 2019

MylesBorins added a commit that referenced this pull request Apr 7, 2019

deps: upgrade npm to 6.9.0
Co-authored-by: Myles Borins <mylesborins@google.com>

PR-URL: #26244
Reviewed-By: Myles Borins <myles.borins@gmail.com>
Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de>

@targos targos referenced this pull request May 7, 2019

Merged

v10.16.0 proposal #27514

BethGriggs added a commit that referenced this pull request May 10, 2019

deps: upgrade npm to 6.9.0
Co-authored-by: Myles Borins <mylesborins@google.com>

PR-URL: #26244
Reviewed-By: Myles Borins <myles.borins@gmail.com>
Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de>

BethGriggs added a commit that referenced this pull request May 10, 2019

deps: upgrade npm to 6.9.0
Co-authored-by: Myles Borins <mylesborins@google.com>

PR-URL: #26244
Reviewed-By: Myles Borins <myles.borins@gmail.com>
Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de>

MylesBorins added a commit that referenced this pull request May 16, 2019

deps: upgrade npm to 6.9.0
Co-authored-by: Myles Borins <mylesborins@google.com>

PR-URL: #26244
Reviewed-By: Myles Borins <myles.borins@gmail.com>
Reviewed-By: Ruben Bridgewater <ruben@bridgewater.de>

BethGriggs added a commit that referenced this pull request May 28, 2019

2019-05-28, Version 10.16.0 'Dubnium' (LTS)
Notable changes:

- deps:
  - icu 63.1 bump (CLDR 34) (Steven R. Loomis)
    [#23715](#23715)
  - upgrade npm to 6.9.0 (Kat Marchán)
    [#26244](#26244)
  - upgrade openssl sources to 1.1.1a (Sam Roberts)
    [#25381](#25381)
  - upgrade to libuv 1.24.1 (cjihrig)
    [#25078](#25078)
- events: add once method to use promises with EventEmitter (Matteo Collina)
  [#26078](#26078)
- n-api: mark thread-safe function as stable (Gabriel Schulhof)
  [#25556](#25556)
- repl: support top-level for-await-of (Shelley Vohr)
  [#23841](#23841)
- zlib:
  - add brotli support (Anna Henningsen)
  [#24938](#24938)

PR-URL: #27514

BethGriggs added a commit that referenced this pull request May 28, 2019

2019-05-28, Version 10.16.0 'Dubnium' (LTS)
Notable changes:

- deps:
  - icu 63.1 bump (CLDR 34) (Steven R. Loomis)
    [#23715](#23715)
  - upgrade npm to 6.9.0 (Kat Marchán)
    [#26244](#26244)
  - upgrade openssl sources to 1.1.1a (Sam Roberts)
    [#25381](#25381)
  - upgrade to libuv 1.24.1 (cjihrig)
    [#25078](#25078)
- events: add once method to use promises with EventEmitter
  (Matteo Collina) [#26078](#26078)
- n-api: mark thread-safe function as stable (Gabriel Schulhof)
  [#25556](#25556)
- repl: support top-level for-await-of (Shelley Vohr)
  [#23841](#23841)
- zlib:
  - add brotli support (Anna Henningsen)
  [#24938](#24938)

PR-URL: #27514

BethGriggs added a commit that referenced this pull request May 28, 2019

2019-05-28, Version 10.16.0 'Dubnium' (LTS)
Notable changes:

- **deps**:
  - update ICU to 64.2 (Ujjwal Sharma)
    [#27361](#27361)
  - upgrade npm to 6.9.0 (Kat Marchán)
    [#26244](#26244)
  - upgrade openssl sources to 1.1.1b (Sam Roberts)
    [#26327](#26327)
  - upgrade to libuv 1.28.0 (cjihrig)
    [#27241](#27241)
- **events**:
  - add once method to use promises with EventEmitter (Matteo Collina)
   [#26078](#26078)
- **n-api**:
  - mark thread-safe function as stable (Gabriel Schulhof)
    [#25556](#25556)
- **repl**:
  - support top-level for-await-of (Shelley Vohr)
    [#23841](#23841)
- **zlib**:
  - add brotli support (Anna Henningsen)
    [#24938](#24938)

PR-URL: #27514

BethGriggs added a commit that referenced this pull request May 28, 2019

2019-05-28, Version 10.16.0 'Dubnium' (LTS)
Notable changes:

- **deps**:
  - update ICU to 64.2 (Ujjwal Sharma)
    [#27361](#27361)
  - upgrade npm to 6.9.0 (Kat Marchán)
    [#26244](#26244)
  - upgrade openssl sources to 1.1.1b (Sam Roberts)
    [#26327](#26327)
  - upgrade to libuv 1.28.0 (cjihrig)
    [#27241](#27241)
- **events**:
  - add once method to use promises with EventEmitter (Matteo Collina)
   [#26078](#26078)
- **n-api**:
  - mark thread-safe function as stable (Gabriel Schulhof)
    [#25556](#25556)
- **repl**:
  - support top-level for-await-of (Shelley Vohr)
    [#23841](#23841)
- **zlib**:
  - add brotli support (Anna Henningsen)
    [#24938](#24938)

PR-URL: #27514
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.