Permalink
Browse files

Stretch shouldn't be aliased anymore.

  • Loading branch information...
chrislea committed Jun 22, 2017
1 parent 943bc66 commit 8bb181bb34f8ba6391511377e757b02ec39ff862
Showing with 0 additions and 4 deletions.
  1. +0 −1 deb/setup_4.x
  2. +0 −1 deb/setup_6.x
  3. +0 −1 deb/setup_7.x
  4. +0 −1 deb/setup_8.x
View
1 deb/setup_4.x 100644 → 100755
@@ -257,7 +257,6 @@ check_alt() {
check_alt "Kali" "sana" "Debian" "jessie"
check_alt "Kali" "kali-rolling" "Debian" "jessie"
check_alt "Debian" "stretch" "Debian" "jessie"
check_alt "Linux Mint" "maya" "Ubuntu" "precise"
check_alt "Linux Mint" "qiana" "Ubuntu" "trusty"
check_alt "Linux Mint" "rafaela" "Ubuntu" "trusty"
View
1 deb/setup_6.x 100644 → 100755
@@ -257,7 +257,6 @@ check_alt() {
check_alt "Kali" "sana" "Debian" "jessie"
check_alt "Kali" "kali-rolling" "Debian" "jessie"
check_alt "Debian" "stretch" "Debian" "jessie"
check_alt "Linux Mint" "maya" "Ubuntu" "precise"
check_alt "Linux Mint" "qiana" "Ubuntu" "trusty"
check_alt "Linux Mint" "rafaela" "Ubuntu" "trusty"
View
1 deb/setup_7.x 100644 → 100755
@@ -257,7 +257,6 @@ check_alt() {
check_alt "Kali" "sana" "Debian" "jessie"
check_alt "Kali" "kali-rolling" "Debian" "jessie"
check_alt "Debian" "stretch" "Debian" "jessie"
check_alt "Linux Mint" "maya" "Ubuntu" "precise"
check_alt "Linux Mint" "qiana" "Ubuntu" "trusty"
check_alt "Linux Mint" "rafaela" "Ubuntu" "trusty"
View
@@ -257,7 +257,6 @@ check_alt() {
check_alt "Kali" "sana" "Debian" "jessie"
check_alt "Kali" "kali-rolling" "Debian" "jessie"
check_alt "Debian" "stretch" "Debian" "jessie"
check_alt "Linux Mint" "maya" "Ubuntu" "precise"
check_alt "Linux Mint" "qiana" "Ubuntu" "trusty"
check_alt "Linux Mint" "rafaela" "Ubuntu" "trusty"

8 comments on commit 8bb181b

@qingduyyy

This comment has been minimized.

Show comment
Hide comment
@qingduyyy

qingduyyy Jun 22, 2017

why strech is not supported now??

qingduyyy replied Jun 22, 2017

why strech is not supported now??

@chrislea

This comment has been minimized.

Show comment
Hide comment
@chrislea

chrislea Jun 22, 2017

Contributor

I think you misunderstand @qingduyyy . Before Stretch was fully released, it was aliased so people running the pre-release of Stretch would get the packages we built for Jessie. Now that Stretch is fully released, we have built packages specifically for Stretch, so there's no more need for the alias to Jessie that we had in place. So really, Stretch is now "properly" supported.

Contributor

chrislea replied Jun 22, 2017

I think you misunderstand @qingduyyy . Before Stretch was fully released, it was aliased so people running the pre-release of Stretch would get the packages we built for Jessie. Now that Stretch is fully released, we have built packages specifically for Stretch, so there's no more need for the alias to Jessie that we had in place. So really, Stretch is now "properly" supported.

@qingduyyy

This comment has been minimized.

Show comment
Hide comment
@qingduyyy

qingduyyy Jun 22, 2017

when i run the code to install node,I get error like this:

Your distribution, identified as "stretch", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues

qingduyyy replied Jun 22, 2017

when i run the code to install node,I get error like this:

Your distribution, identified as "stretch", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues

@qingduyyy

This comment has been minimized.

Show comment
Hide comment
@qingduyyy

qingduyyy Jun 22, 2017

@chrislea my install code is
curl -sL https://deb.nodesource.com/setup_7.x | bash - && apt-get install -y nodejs

qingduyyy replied Jun 22, 2017

@chrislea my install code is
curl -sL https://deb.nodesource.com/setup_7.x | bash - && apt-get install -y nodejs

@chrislea

This comment has been minimized.

Show comment
Hide comment
@chrislea

chrislea Jun 22, 2017

Contributor

Node.js 7.x is going to be deprecated by the end of the month I believe. You should really move to 8.x right away. If you use the setup_8.x script, it should work fine.

Contributor

chrislea replied Jun 22, 2017

Node.js 7.x is going to be deprecated by the end of the month I believe. You should really move to 8.x right away. If you use the setup_8.x script, it should work fine.

@qingduyyy

This comment has been minimized.

Show comment
Hide comment
@qingduyyy

qingduyyy Jun 22, 2017

ok,thanks for your answer:)

qingduyyy replied Jun 22, 2017

ok,thanks for your answer:)

@dmonu

This comment has been minimized.

Show comment
Hide comment
@dmonu

dmonu Jun 22, 2017

The setup_4.x script doesn't work for stretch.

dmonu replied Jun 22, 2017

The setup_4.x script doesn't work for stretch.

@chrislea

This comment has been minimized.

Show comment
Hide comment
@chrislea

chrislea Jun 22, 2017

Contributor

@dmonu closed in #481 .

Contributor

chrislea replied Jun 22, 2017

@dmonu closed in #481 .

Please sign in to comment.