Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

404 Not Found #276

Closed
nkhine opened this Issue · 5 comments

2 participants

@nkhine

Continuing from #266 (comment)

I am unable to setup my nodester account, as when i do:

☺  nodester user setpass sendtoken                                                                                                                                                
    nodester ERROR Username and password not set in config.
    Please run nodester user setup <username> <password>

and then when i run the:

  ☹  nodester user setup (my email address) (pasword)                                                                                                                                  
       nodester info verifying credentials
       nodester info { response: '<html>\r\n<head><title>404 Not Found</title></head>\r\n<body bgcolor="white">\r\n<center><h1>404 Not Found</h1></center>\r\n<hr <center>nginx/1.0.6</center>\r\n</body>\r\n</html>\r\n', errorCode: 404 }
       nodester ERROR Fatal Error! API Response: <html>
       <head><title>404 Not Found</title></head>
       <body bgcolor="white">
       <center><h1>404 Not Found</h1></center>
       <hr><center>nginx/1.0.6</center>
       </body>
       </html>

       Reason: HTTP Error 404 returned.

i have shut down my nginx on my machine. besides the version i am running is:

       ☺  nginx -v                                                                                                                                       
            nginx: nginx version: ngx_openresty/1.0.10.24

then to ping:

☺ ping nodester.com

PING nodester.com (50.16.203.53): 56 data bytes
64 bytes from 50.16.203.53: icmp_seq=0 ttl=43 time=116.725 ms
64 bytes from 50.16.203.53: icmp_seq=1 ttl=43 time=117.325 ms

☺  nslookup 50.16.203.53                                                                                                                                                          
Server:     192.168.0.254
Address:    192.168.0.254#53

Non-authoritative answer:
53.203.16.50.in-addr.arpa   name = nodester.com.

Authoritative answers can be found from:
203.16.50.in-addr.arpa  nameserver = pdns2.ultradns.net.
203.16.50.in-addr.arpa  nameserver = pdns1.ultradns.net.
203.16.50.in-addr.arpa  nameserver = pdns6.ultradns.co.uk.
203.16.50.in-addr.arpa  nameserver = pdns5.ultradns.info.
203.16.50.in-addr.arpa  nameserver = pdns4.ultradns.org.
203.16.50.in-addr.arpa  nameserver = pdns3.ultradns.org.

any advice much appreciated.

@chrismatthieu
Collaborator

We don't use nginx. Not sure where that response is coming from...

@nkhine

i have setup this on a different machine and i get the same error:

[khine@ns366116 ~]$ nodester -v
0.2.35
[khine@ns366116 ~]$ nodester user setup norman@khine.net password
nodester info verifying credentials
nodester info { response: '<html>\r\n<head><title>404 Not Found</title></head>\r\n<body bgcolor="white">\r\n<center><h1>404 Not Found</h1></center>\r\n<hr><center>nginx/1.0.6</center>\r\n</body>\r\n</html>\r\n',
  errorCode: 404 }
nodester ERROR Fatal Error! API Response: <html>
<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.0.6</center>
</body>
</html>

Reason: HTTP Error 404 returned.

i don't have nginx running on this machine!

here is the $ nslookup results:

[khine@ns366116 ~]$ nslookup 50.16.203.53
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
53.203.16.50.in-addr.arpa       name = nodester.com.

Authoritative answers can be found from:
203.16.50.in-addr.arpa  nameserver = pdns6.ultradns.co.uk.
203.16.50.in-addr.arpa  nameserver = pdns1.ultradns.net.
203.16.50.in-addr.arpa  nameserver = pdns2.ultradns.net.
203.16.50.in-addr.arpa  nameserver = pdns5.ultradns.info.
203.16.50.in-addr.arpa  nameserver = pdns3.ultradns.org.
203.16.50.in-addr.arpa  nameserver = pdns4.ultradns.org.
pdns1.ultradns.net      internet address = 204.74.108.1
pdns1.ultradns.net      has AAAA address 2001:502:f3ff::1
pdns2.ultradns.net      internet address = 204.74.109.1
pdns3.ultradns.org      internet address = 199.7.68.1
pdns4.ultradns.org      internet address = 199.7.69.1
pdns4.ultradns.org      has AAAA address 2001:502:4612::1
pdns5.ultradns.info     internet address = 204.74.114.1
pdns6.ultradns.co.uk    internet address = 204.74.115.1

is the nslookup correct and is there anything else i can do to check what is going on?

what goes on?

@nkhine

any advise on this issue, as i con't seem to connect at all. i tried even a new EC2 machine to see it it is just my machine, but i get the same.

@chrismatthieu
Collaborator

This is what I get back from nslookup 50.16.203.53

Server: 10.0.1.1
Address: 10.0.1.1#53

Non-authoritative answer:
53.203.16.50.in-addr.arpa name = nodester.com.

Authoritative answers can be found from:

{no other entries}

@nkhine

i rebuilt my machine and the nodester works fine, so i close this issue.

@nkhine nkhine closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.