Nodes lose their position when returned via undo #96

Closed
bergie opened this Issue Feb 25, 2014 · 2 comments

Comments

Projects
None yet
3 participants
Owner

bergie commented Feb 25, 2014

Undo is now able to return deleted nodes back to the graph. However, they seem to lose their position.

screenshot 2014-02-25 at 12 01 14

screenshot 2014-02-25 at 12 01 20

screenshot 2014-02-25 at 12 13 37

screenshot 2014-02-25 at 12 01 32

Ping @jonnor

Owner

forresto commented Feb 25, 2014

Funny that the import comes back to the right place.

@bergie bergie added the bug label Feb 25, 2014

jonnor pushed a commit to jonnor/noflo-ui that referenced this issue Feb 26, 2014

TEMP: Change metadata on removeNode/Edge/Group
Journal was not getting enough information to recreate the position
of nodes, which is stored in the metadata.
Fixes noflo/noflo-ui#96

jonnor added a commit to jonnor/noflo that referenced this issue Feb 26, 2014

Graph: Emit metadata changes on node/edge/ports removal
Needed for the journal to be able to restore metadata when undoing removals.
Fixes noflo/noflo-ui#96, undoing node removal resets position to 0,0
Owner

jonnor commented Feb 26, 2014

Pullrequest with fix: noflo/noflo#148
I noted this as a know issue in the undo-redo pullrequest ;)

KevinHoward added a commit to KevinHoward/noflo that referenced this issue Jun 30, 2014

Graph: Emit metadata changes on node/edge/ports removal
Needed for the journal to be able to restore metadata when undoing removals.
Fixes noflo/noflo-ui#96, undoing node removal resets position to 0,0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment